powered by Jive Software

Openfire Cluster + Azure

Hello, opening a new topic as I have tried everything and I can’t seem to make this work. I have two VM’s on Azure (debian 10.5), each one running a instance of Openfire 4.5.3, they are in the same virtual network, and if I ping from from one to another, there is a response, so I think anything network related should be out of the question. They have the same xmpp domain name (example. com) and differents fqdn (server1. example.com & server2. example.com)

Using the hazelcast plugin (2.5.0) with this config

<join>
            <multicast enabled="false"/>
            <tcp-ip enabled="true">
                <member>10.1.0.4</member>
                <member>10.1.0.5</member>
            </tcp-ip>
            <aws enabled="false"/>
        </join>

        <interfaces enabled="true">
            <interface>10.1.0.*</interface>
        </interfaces>

the plugin is enabled on both and it starts, but it only shows its own server (only shows 1 node in each one), they are both pointing to the same MS SQL database. Anything else I can try to make this work? Thanks

Is there a firewall between the two blocking access TCP:5701 ?

I don’t think so, as I’m able to telnet & ping from one to another (using public/private ip) to that particular port
I don’t know whats wrong, so any pointer would be greatly appreciated, thanks!

I have interfaces enabled="false" in my setup (although I doubt if that would make a difference.

Try increasing the log level to trace or all. That will cause Hazelcast to log what it is trying to do. Maybe we can get a hint from that.

alright, all my setup was correct, it was just a dumb error, was loading the config file from the wrong location :man_facepalming: thank you guys now everything loads correctly

1 Like