Openfire, disable sasl

please tell me where that button is that allowes me to disable sasl so that pidgin can besides connect also authorize new buddies.

I am really pissed off, this question has been asked over and over again throughout the net for years and years now…

so where is the answer, and please a short one that can be understood by the window user that got everything else to work by just clicking next->next->next.

Hi werd,

Could you be more specific? I’m using the latest openfire version and a recent pidgin (2.7.3)

I’m not experiencing the behaviour you’re describing. I can authorize new contacts perfectly fine.

I understand you’re frustrated, but please keep the conversation civil.

I have never done this, nor needed/desired to as we use groups for buddies and 95% of our users use Spark and only a few on pidgin. I don’t think there is a button (maybe I am wrong???). From what I have seen, you need to set this in the system properties. You can find property settings for SASL at the following link (you need to scroll down a little):

Maybe this would help:

IMHO, if you want a simple Next, Next, Next click and choose this button or that button, then you probably need to tell your company to buy an IM solution… If you are afraid of setting custom properties or editing the config file, Openfire is probably not for you. Or, you could learn it, there is a lot of great help from the Openfire commmunity on most topics. I don’t think it is right to get upset at those who have put together (and maintain) an awesome FREE IM server solution! Openfire is an awesome platform and a lot of things are designed so that admins are able to customize it how they need it…the other side of this is that you need to be able to dive into config files, set your own custom properties, etc…this is the fun part of it too!

With a default installation of Openfire, either on xp32, xp64, or win7x64, which is completed in a most userfriendly fassion, Openfire seems only able to allow users to add buddies/friends in Spark, and in no other XMPP client, or at least not in Cutecom or Pidgin.

According to 5 years of forumposts this problem is caused by openfire not handling sasl in the way it should be handled, and besides advice, or even documentation that seems completely wrong, like for example the 2 links from ragenkagen;

besides this beying complete gibrish… where in the xml am i supposed to put it. . i assume it needs to be placed between but why is it not documented.

The second link,

also gives a solution which is completely wrong,

should be

and even though that gets added it in the system properties of openfire correctly, it does not resolve the problem.

But most of all, this problem should not be here. it was there in 2007, and it is here now, and the only fix seems to use the spark/openfire combo that allowes the incorrect sasl procedure, or to bypass the problem by creating a group and allow new users to automaticly join.


openfire = nextnextnext

and it should work right out of the box, but does not allow other XMPP clients to authenticate new friends, except with Spark. i’m not afraid of options and like to tenker with them myself. However, not or badly documenting main features (adding friends to the list is a core feature of a IM service), and then having to search all over the place is not part of the fun.

Sry for my bad temper demonstrated in my previous post, its free software and im glad i may use it… that doesnt however mean it cant drive me crazy

so yea…

-adding friends in non-Spark clients…

bcx, did you have to do anything special to get this working for you?


Am i correct in assuming that you too, cannot make this XMPP server to allow other XMPP clients to add friends, and that you too, like me, are bypassing this problem by the use of groups?

if so, then dont you agree that this is core functionality that should work out of the box, or at least have a detailed guide on how to make it work if for some reason, this functionality is disabled as default on purpose.

I have never tried to set this up. One of the things I liked about Openfire was that I can set groups in the server…well, we actually use AD to do this and then pull them from AD.

Our previous IM solution did not have this capability…and it was a major pain for me as the admin…because I either had to go in and add all the other users that a user in each of their clients or constantly explain to them how to add other users (they don’t like to follow instructions here, but would rather ask everytime)…groups are much easier for our needs…because everybody has the users they need already and if they want their own custom groups for users they IM most frequently, then they can just make there own custom ones and pull users from their existing groups into this.

I understand the value of groups in environments where admins manage communications, but in contrary to the function of groups which in my view is a additional feature, adding friends is core functionality of instant messaging. msn would cirtainly not work if it only had groups, no IM service would work with only that option, and so cant mine.

but i forgot u allready stated to use mostly spark which wouldnt have this problem anyway.

The way the server is setup btw, is in a isolated lan, and when trying to add friends, in pidgin it sais authenticating, 404 page not found … but nowhere in settings i can see it refer to outside ips or www, and during authenticating, the contact to be added gets no request.

Pidgin is such an annoying client (and i’m using and testing with lots of them). It is always pita when i have to install it again to test some reported issues. E.g. i had to delete whole profile to get rid of all groups that were pulled to pidgin before, though i have disabled group sharing and all other clients stopped showing them. Another brilliant “feature” of Pidgin…

Anyway. I have tested and i was able to add and authorize new buddy both Pidgin -> Exodus way and Exodus -> Pidgin. Unless this is only isolated to Pidgin -> Pidgin scenario. Then i will have to create another windows account to test this. I’ve used Pidgin 2.7.11 and Openfire 3.7.0. I have even enabled SSL requirement on the server and i don’t have any sasl stuff in my config.

I have tested Pidgin -> Pidgin and adding buddies works. How are you adding buddies? You should specify username@servername in the Buddy’s username field of the buddy you are trying to add. Because it won’t do anything if you just type username part.

Thank you wr00t. you are a genious and im a fool. This was indeed the solution, one that i couldve and shouldve figured out myself. So Im sorry for my bad attitude, i was misdirected by outdated forumposts that made it seem like the problem was with openfire.

As for pidgin, you could copy and rar the pidgin dir and use it as portable app. This is how i bypass most anoyances

The reason why i find pidgin so important is that most ppl i know that use msn, connect through pidgin, If openfire works through pidgin, then that would have the least impact on them and they can keep using their clients as they are allready used to.

You say you tested lots of clients. i have tested some, but am still searching for a nice windows IM/phone/videophone client. Qutecom is what ive found so far, happen to know a better alternative?

Don’t know of any client which will be great for desktop, phone and also video chats. Usually they best at one thing Don’t know much about mobile or video chat clients, i’m mostly desktop IM user. Speaking about video chats, Dele, a community member, was maintaining Redfire plugin (maybe still active) for Openfire and Spark to do video calls.

I think you will have to choose the best client in every category and use 3 of them for every platform/case. Or you will have to pay a lot to have one client for all platforms.