powered by Jive Software

Openfire disconnecting users

Hello all, I’ve been rolling out an openfire installation over the last month or so and users are reporting that they are being disconnected from the server at various times of the day (myself included.) I am using openfire 3.7.1, and the majority of users are using Spark 2.6.3. I have been testing other clients with this install as well (pidgin) and they too are experiencing the issue. I have attached my pidgin log for reference, but the relevant portion seems to be:

(14:20:49) jabber: Sending (matth@chatserver/d838f12a):

(14:20:49) jabber: Recv (68):

(14:21:49) jabber: Sending (matth@chatserver/d838f12a):

(14:21:49) jabber: Recv (68):

(14:21:49) connection: Connection error on 07DF5DF8 (reason: 0 description: Lost connection with server: Remote host closed connection.)

(14:21:49) account: Disconnecting account matth@chatserver.domain.domain/ (024F05D8)

(14:21:49) connection: Disconnecting connection 07DF5DF8

(14:21:49) connection: Deactivating keepalive.

(14:21:49) jabber: Sending (matth@chatserver/d838f12a): </stream:stream>

(14:21:49) connection: Destroying connection 07DF5DF8

The only thing I see in the debug log during these time periods is :

2012.08.06 14:14:26 org.apache.mina.filter.executor.ExecutorFilter - Exiting since queue is empty for /10.64.177.204:57552

2012.08.06 14:14:26 org.apache.mina.filter.executor.ExecutorFilter - Launching thread for /10.64.177.204:57552

I have been through numerous older threads about this issue. The majority poing to setting the idle client timeout to -1. Doing this did not resolve the issue.

Any ideas? I’m starting to beat my head against the wall. This seems to happen somewhat randomly, sometimes every 10-15 minutes, sometimes only once a day or so. This is a Windows 2008 R2 box
openfire client debug.txt.zip (1388 Bytes)

As i see “keepalive” in the log, this can be realted to idle clients disconnecting. To make sure, you have added:

xmpp.client.idle

system property?

Try setting it to other value instead of -1. Mine is 600000 (10 minutes). This will give a client a chance to send keepalive packet and also should disconnect idle connections soon enough.

Yea, I found this in another thread as well. Tried -1 and very large values like you suggested, neither had any effect. I tried disabling idle client disconnection as well.

Was an answer found to this issue? i am experiencing the same for openfire 3.9.3?