powered by Jive Software

Openfire doesn't load cyrillic user names (LDAP)

I’v just installed Openfire on Windows 2003 server connecting it to my Active Directory. And when I open “Users/Groups” tab, I see only latin users. The most of our user names are cyrillic, and they are absent in openfire. Therefore I cannot authorize with cyrillic username by jabber-client. I tried embedded database and mysql external database with utf8 character set, also I added “&characterEncoding=UTF-8” to database.defaultProvider.serverURL property and in all cases my cyrillic users are invisible. Does openfire not supported cyrillic user-names?

what version of mysql are you using? If using the newest, than you might want to try using utf8mb4. also, try added useUnicode=true

jdbc:mysql://localhost:3306/your_database?useUnicode=true

You may have to update the mysql driver as well, which is easy to do. just download MySQL :: Begin Your Download - mysql-connector-java-5.1.36.zip and replace mysql.jar in openfire\lib

I should note, that I’m not using cyrillic, but this is where I would start

I have old version of mysql server. But if the problem coused by mysql server then why is the same problem with embedded database server?

no idea. have you tried reinstalling, and selecting a cyrillic language during install? is the default language of the OS set to a cyrillic language?

Yes, I have tried reinstalling, also tried install ntlm-patch. And yes, default language of my Windows 2003 server is set to Russian. But cyrillic language is absent in list during install.
I also noticed that I can see users whith russian representations (field “Name”), but not users with russian login names (field “Username”). And I suspect that the problem is not concerned with database because openfire take usernames directly from Active Directory by LDAP. Isn’t it?
So, how can I find the cause of error? Any debug mode? Logs?

strange, as I see

as a language selection.

Hopefully someone with experience with cyrillic will jump in soon!

I solved the problem by installing previous version of openfire (3.4.0). I will try various versions in order to find the newest cyrillic-compatible version. Thanks all for answers.

So I have next results. All Openfire versions 3.10.x don’t show cyrillic users in the list. It show number 247 but show only 151 our latin users, it show 3 pages but 3-rd page is empty. Language selection is Русский (ru_RU). The last cyriilic compatible version at the moment is 3.9.3. How can I make bug report?

Hello Yury, you have the results openfire run on older versions of 3.9.3 supporting Cyrillic?

version 4.1.3 - don’t show cyrillic users in the list.

Now v.3.9.3 works correctly.

When this fucking bug will be fixed?

no need to use foul language. The project is supported by volunteers.

my guess, this was introduce in with [OF-830] LDAP shared groups disappear after some time - IgniteRealtime JIRA

ok. sorry.

but for some reason it worked in 3.9.3 and does not work in 4.x.x?

Why break something that works?

its an unintentional bug likely introduced while fixing another bug. it happens

Yes, in the words of Forrest Gump - “Shit happens”.

I hope that this bug will be fixed. I really liked Openfire.

[OF-1305] Openfire doesn’t load user names with multi-byte characters from LDAP/AD - IgniteRealtime JIRA