Openfire Down

My openfire is Down and the only error that appear in /var/log/openfire/error.log is:

2011.11.01 09:41:58 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: /usr/share/openfire/plugins/webchat

java.lang.NoClassDefFoundError: org/mortbay/jetty/servlet/Context

at java.lang.Class.getDeclaredConstructors0(Native Method)

at java.lang.Class.privateGetDeclaredConstructors(

at java.lang.Class.getConstructor0(

at java.lang.Class.newInstance0(

at java.lang.Class.newInstance(

at org.jivesoftware.openfire.container.PluginManager.loadPlugin( :420)

at org.jivesoftware.openfire.container.PluginManager.access$300( :80)

at org.jivesoftware.openfire.container.PluginManager$

at java.util.concurrent.Executors$

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(

at java.util.concurrent.FutureTask.runAndReset(

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(

at java.util.concurrent.ScheduledThreadPoolExecutor$

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask( 886)

at java.util.concurrent.ThreadPoolExecutor$


Caused by: java.lang.ClassNotFoundException: org.mortbay.jetty.servlet.Context


at Method)


at java.lang.ClassLoader.loadClass(

at java.lang.ClassLoader.loadClass(

… 17 more

The system is Debian Squeeze, and because this error (or not) i can’t go inside Web Admin interface. The 9090 and 9091 are opened but connection don’t complete.

Some help here, please.

remove the webchat plugin from plugins folder…both the folder as well as jar file

I have the same issue. I have tried:

reinstalling ofmeet.jar file

update webchat.war file

change the xmpp.pep.enabled = false

delete webchat.war file avoid the notFound exception but it says: openfire meeting could not be loaded.

Increase the openfire memory

none of them worked

The weird part is that it was working without any issue. But I have changed my local users by LDAP connection and it got down.

any help will be appreciated.

thanks in advance