Openfire Enterprise 3.4.5 Fastpath web chat


Today i installed 3.4.5 enterprise and added commercial pluginn fastpath and configured well .

now when i tried hXXp://mydomain:9090/webchat it shows me my work group

but live help shows offline

help me how to enable it for LIVE,.


Yukari !!!

Hey Yukari,

In order for the live chat to be active, an agent must be logged into the openfire server with spark. An agent is a user that is present on the openfire server, and represented in one of the fast path queues.


Hi Sean…

when you say spark… you mean sparkweb as well ??

i’ve justed installed openfire and enterprise to use fastpath… this is what i’m doing for test:

  1. created user account

  2. added user to fastpath workgroup (inside a queue)

  3. logged as user in sparkweb (same domain as openfire)

  4. opened http://mydomain:9090/webchat/ and saw the workgroup offline

  5. also came back to openfire / fastpath workgroup administration to see Agents (active/total) and see active as zero all the time.

can you help me out ?

it worked…

i needed to install spark as a client with faspath pluggin

works great now


Sorry, but I still dont get the concept of Fastpath for the customer facing part.

Agents have to use Spark and no other Client, OK, that is inline with our company policy but does not help too much when testing from Home with iChat btw.

  1. I see that Webchat is still considered a commercial plugin but this is the one to use for the customer side. If this is true, what is then WEBCHAT for and all its related HTML tuning on the Fastpath Admin page. I just downloaded the fastpath plugin but NOT yet the webchat.jar!

  2. Also I am sure that I saw the Tools->Webchat link on the Admin page yesterday but it is now gone.

When opening the /webchat/ as in the link on the above post I get a



Powered by Jetty://

Maybe that is also the reason that I dont see icons used on the Form UI page anymore.

All the other Admin pages work perfectly…

  1. Is itt really needed to have the webchat running on port 9090? Since this is the Admin port I would rather close it down on the firewall and not open it to the world.

Stupid man I am…



1 Like

Hi we encounteer the same problem.

It seems that if you install the fastpath plugin you’ll need to deploy the webchat app on some other server…

I test it on weblogic and tomcat and it somethow work…

1 Like