powered by Jive Software

Openfire failure on Mac OSX 10.12.4

Hi buddies,

I am new to openfire. I tried to install openfire 4.1.3 on my mac which is OSX 10.12.4.

Here were what I did:

  1. installed openfire 4.1.3

  2. Installed Java

  3. Installed Xampp

  4. launched Apach Web server and Php server

5 Configured openfire via “localhost:9090”, created the Mysql DB with credentials and openfire login credentials. All looked going well. But after that the openfire server seemed down. I could never access it via “localhost:9090”. “netstat -an|grep 9090” returned nothing. It looked the openfire server was down. I was thinking of start the server through Termnial but I could access the /usr/local/openfire with permission deined error. Sudo didn’t work.

  1. I also noticed a strange thing, after openfire being installed, no GUI could be found. I searched in Applications.

Please could I have your advice? Many thanks!

Qing

After a few attempts, I made it work finally!

Here are the steps:

1 Uninstall openfire from terminal via commands below:

  sudo rm -rf /usr/local/openfire

  sudo rm -rf /Library/PreferencePanes/Openfire.prefPane
  sudo rm -rf /Library/LaunchDaemons/org.jivesoftware.openfire.plist
  sudo rm -rf /Library/Receipts/Openfire.pkg
  1. reboot mac

  2. reinstall openfire

  3. After installation, if successfully, openfire console GUI icon should be sitting in Other of Mac system preference. Click the openfire icon to launch the console.

  4. The openfire server can be start/stop by clicking the button below Status. It works for me:)

  5. click “Open admin console” button, it will guide you to browser for configuring the openfire server just as “localhost:9090”; don’t forget to launch Xampp(Web, PhP, Mysql)

  6. last thing I would like to recommend is , this time, I skipped the step of setting openfire login credentials. I experienced sth strange before, after creating my own credentials, finally having trouble to access openfire server(Same issue could be found on the Web, seems no root cause being found yet). As I just want to make some tests, the security is not my concern. the default user/pasword is admin/admin.

Don’t know how to post pictures sorry.

Enjoy…

Cheers!

Hi guys,
Thank you Qing for show me the openfire files, that gave me an idea of what was going on: it’s not about re-install, or not at least in openfire 4.2.2 with mac 10.13.3, it’s about 2 things:

  1. Java path especified in /usr/local/openfire/bin/openfire.sh
  2. permissions in /usr/local/openfire folder and subfolders.

How to make it works:

  1. Install JDK
  2. Install XAMPP
  3. Install openfire 4.2.2 (in my case)
  4. look for your java path (you can open a console and use: /usr/libexec/java_home)
  5. modify the permissions for folder and sub folder of /usr/local/openfire/ to read/write
  6. open the file openfire.sh (located in /usr/local/openfire/bin/)
    6.1. change the java path home for the real one in the line: JAVA_HOME=

Now you can start openfire using sh command from console or you can do it using the system preferences UI icon

Note: during installation, remember to set up the right domain:
“Ensure that the XMPP domain (property xmpp.domain) is a FQDN that can be resolved via DNS on the Internet. This also needs to be the hostname of the machine running Openfire.”