powered by Jive Software

OpenFire fresh install, "No users in the system"

Fresh install of 3.8.2 on Windows 2012. MySQL DB. Running as Windows service. Created 16 users total. Working fine with one exception; in the admin console, I get “No users in the system” when I go to the user summary page. I can search and find any of the 16 users, and if I go to advanced search and type *, I see the whole list. But not under summary.

This is what I see in error.log:

"2013.09.10 19:16:05 org.jivesoftware.database.DbConnectionManager - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘OPTION SQL_SELECT_LIMIT=DEFAULT’ at line 1

com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘OPTION SQL_SELECT_LIMIT=DEFAULT’ at line 1"

Any thoughts?

1 Like

hmm… I use mysql 5.1.x as my database and 3.8.2 (on linux though) and no issue… we have way over your 16 users in the system…

did you do the database prep prior to openfire install?

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/database .html

I did do the DB setup as per that document. Everything else works. Just not sure why I can’t see the user list…

you may want try updating the included mysql driver with this one

http://dev.mysql.com/downloads/connector/j/#downloads

Seems related http://community.igniterealtime.org/message/232630#232630

@Charlie - yes the fix appears to be the updated mysql jdbc driver. see the link wroot posted for the fix.