OpenFire group sharing problem (group disappears from rosters)

Hello to everyone.

There’s some strange problem with my OpenFire 3.8.2.

I’ve got a couple of shared groups. All the groups are taken from Active Directory.

Some of them work perfectly, but the others constantly disappear from users’ rosters.

So, I’m going to Users/Groups -> Groups, then searching for the group.

As a result - there’s a mark “Enable contact list group sharing”, but the shared group name field is empty.

I’m writing a name, sharing this group with other groups, then clicking “Save contact list settings”.

After some time this groups appears in rosters.

And after a bit more period of time, there’s the same deal. It disapperas from rosters, and the field “shared group name” in group properties is empty.

Any ideas about how to debug and fix it?

Nobody has no ideas?

Try to purge the roster cache. Sounds like OF-141

I’ve tried to reduce database connection timeout, and still no effect.

The groups are still disappearing.

Maybe some more ideas? =)

By the way, not all of the published groups disappear. Just two of them =(

I’ve purged the caches for everything and I still have this issue. I have about 15 AD groups that are shared and only 2 or 3 of them are showing up. Going in and making a change on one and then saving it seems to refresh it for all users who can then see it in Spark, but that’s a pain to update after every restart of the service.

I have the same problem with Openfire 3.9.3.

Same problem with Openfire 3.9.3 here as well. Making the change seems to work sometimes. Other times I need to restart the whole server.

I just wanted to raise my hand as another who is having this problem in 3.9.3. Groups disappear from the roster but upon re-saving them in the web interface they appear in the roster again only to have the same dissappearing act the next day. I’d changed a couple of settings such as cache.username2roster.size and cache.vcardCache.size as recommended in some other LDAP related threads. They seem to have sped up the general browsing behavior in the web administration but once you actually try to drill into a group things seem to hit a standstill now.

Finally ended up having to give up doing groups via LDAP to AD, and disabled them via .

So now we went back to having the support staff maintain the groups by adding new users into them, which really sucks. Honestly looking into other options like Lync, Trillians server and Prosody at this point because of how ignored the issue is around here.

Hey, Openfire Developers, what about any comments on the problem?

Not so much ignored, but rather the lack of developers here, especially with expertise in LDAP.

Don’t think it’s a big problem for developers.

I suppose it may depend on AD objects count.

For example, standard powershell query returns not more than 1000 objects.

But you can always use “-ResultSize Unlimited” when you need it.

If you can propose a patch, it can be submitted and a new nightly build will have it for testing.

Are there any solutions. exactly the same issue ((

Same Issue.

would be nice to have a fix for this.

same problem with 3.9.3. I am going to have to restore back to 3.7.1 till this is resolved.

Same problem in 3.9.3 with an AD, some groups share disappear and i need to validate them back each time the service is put offline…

I still have yet to experience this issue. I’m not sure whats different with my configuration verses everyone else. I’m sure the devs will get it resolved though.