powered by Jive Software

OpenFire inaccessible after Upgrade to 3.9.1

After upgrading my OpenFire instance from version 3.6.4 to 3.9.1 it is not accessible anymore.

Error message on the client:

13:31:06 *** Connection to JABBER has failed: system errorcode "10061".

On the web interface I get the login form, but after entering my credentials I only get this Exception:

java.lang.NoClassDefFoundError: Could not initialize class org.jivesoftware.openfire.admin.AdminManager$AdminManagerContainer

There are no new entries showing up in the log files when I try to connect or login. There are no error messages in the log files on startup.

The system is a debian 6.0 linux, OpenFire was installed via the provided .deb packages.

I am having the exact same problem

Installed using the generic tar file. openfire_3_9_1.tar.gz

Had to revert back to the original 3.6.4 version.

Does anyone have an idea where to start looking for issue?

Are there additional steps required for the leap from 3.6.x.to 3.9.x?

Thanks

Check out the lib/ folder and make sure there is no old bouncycastle file in there, but only new ones like so:

/opt/openfire/lib/bcpg-jdk15on.jar

/opt/openfire/lib/bcprov-jdk15on.jar

/opt/openfire/lib/bcpkix-jdk15on.jar

daryl

No old versions for me:

ls -l bc*

-rw-r----- 1 openfire openfire 248366 Feb 6 21:34 bcpg-jdk15on.jar

-rw-r----- 1 openfire openfire 629662 Feb 6 21:34 bcpkix-jdk15on.jar

-rw-r----- 1 openfire openfire 2476362 Feb 6 21:34 bcprov-jdk15on.jar

I just updated to 3.9.3 with no major issues other than having to remove the gateway plugin. I followed exactly the same process as before

Maybe try that version.