powered by Jive Software

Openfire Installation Error

I’m attempting to do a fresh, clean, install of Openfire 3.7.0 on a Windows 2008 R2 machine with SQL Server 2008 R2 installed.

The JDBC Driver Class code is: net.sourceforge.jtds.jdbc.Driver

The URL : jdbc:jtds:sqlserver://ServerIP:1433/Openfire;appName=jive

I’ve tried using server name instead of IP. I’ve tried with and without the 1433. The most recent error (and most common) I’m seeing in the log is below. Help!!!

2011.06.20 22:35:05 Prototype

java.sql.SQLException: Network error IOException: Connection refused: connect

  at net.sourceforge.jtds.jdbc.ConnectionJDBC2.<init>(ConnectionJDBC2.java:385)

  at net.sourceforge.jtds.jdbc.ConnectionJDBC3.<init>(ConnectionJDBC3.java:50)

  at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:182)

  at java.sql.DriverManager.getConnection(Unknown Source)

  at java.sql.DriverManager.getConnection(Unknown Source)

  at org.logicalcobwebs.proxool.DefaultConnectionBuilder.buildConnection(DefaultConnectionBuilder.java:39)

  at org.logicalcobwebs.proxool.Prototyper.buildConnection(Prototyper.java:159)

  at org.logicalcobwebs.proxool.Prototyper.sweep(Prototyper.java:102)

  at org.logicalcobwebs.proxool.PrototyperThread.run(PrototyperThread.java:44)

Caused by: java.net.ConnectException: Connection refused: connect

  at java.net.PlainSocketImpl.socketConnect(Native Method)

  at java.net.PlainSocketImpl.doConnect(Unknown Source)

  at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

  at java.net.PlainSocketImpl.connect(Unknown Source)

  at java.net.SocksSocketImpl.connect(Unknown Source)

  at java.net.Socket.connect(Unknown Source)

  at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)

  at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

  at java.lang.reflect.Method.invoke(Unknown Source)

  at net.sourceforge.jtds.jdbc.SharedSocket.createSocketForJDBC3(SharedSocket.java:304)

  at net.sourceforge.jtds.jdbc.SharedSocket.<init>(SharedSocket.java:255)

  at net.sourceforge.jtds.jdbc.ConnectionJDBC2.<init>(ConnectionJDBC2.java:310)

anyone can help me???

help!

I have never used Openfire with the external database, but Connection refused gives an impression you are not providing correct credentials for your database.

wroot is right, Connection Refused error usually means Java was able to talk with your database server, but the database server refused to let it connect. Perhaps the port isn’t open, or the database server is not configured to allow connections over the network?

I just registered to make my own post with this same issue. I have installed open fire before with this same server and I am recieving the same error on this install. I tried with the Microsoft SQL Server database and also the mysql database, I tried on my Windows server 2008 Cloud server and my windows 7 Dev box. No matter where I try I am getting this same issue.

Also the mysql database schema has an issue with onRoster. Which can be easily fixed, but it stops a smooth install. What is going on with this release?

Joe Page wrote:

What is going on with this release?

Just a clarification. Are you talking about 3.8.2 or like the topic starter 3.7.0?