powered by Jive Software

Openfire+LDAP ( Erro no login )

Olá Galera,

Estou com um problema na integração do openfire com o ldap. Faço toda a instalação(wizard) e testes do openfire com o ldap, não aparece erro algum. No primeiro acesso, acesso o admin console com um usuário (usúario do ldap definido como administrador na instalação) normalmente, aparecendo todos os usuários do ldap. Mas, depois, quando reinicio o servidor, vou logar novamente, aparece um erro dizendo que o usuário não existe. Depois disso, só conecto com o usuário e senha padrão do openfire (admin:admin), e nas configurações do servidor não vejo a conexão com o ldap, é como se não tivesse salvo as configurações anteriores.

Erro: “Login falhou: tenha certeza que seu usuário e senha estejam corretos e que você seja administrador ou moderador.”

Agradeço desde já.

Por curiosidade qual a versão de openfire que você esta usando e em que sistema operacional ele esta rodando.

Esse problema já me aconteceu no openfire 3.7.0, se você desligava o servidor sem parar o serviço de openfire ele perdia as configurações de conexão.

Aguardando resposta

Olá Christian,

A versão é a 3.7.1, e o SO é Linux Debian 6.0. O problema acontece quando restarto o serviço.

Att,

Xavier

Bom Día Xavier!

Humm.

Primeiro.

Quando você reinicia o servidor você para o serviço do Openfire primeiro e depois manda reiniciar o Servidor?

Segundo.

Que banco você esta usando para o Openfire?

Terceiro.

Você já deu uma olhada se esta salvando as configurações de conexão de LDAP no banco?

Da uma olhada na tabela ofProperty verifica se as configurações LDAP esta preenchidas como ldap.host, ldap.port, ldap.baseDN e outros .

Aguardando resposta

XD

Christian,

Primeiro.

Estando no linux, executo o comando: “/etc/init.d/openfire restart” ou “/etc/init.d/openfire stop” e depois “/etc/init.d/openfire start”.

Segundo

Seguindo o wizard de instalação, escolho o banco Mysql instalado localmente.

Terceiro.

Como falei anteriormente, sigo o wizard e faço todos os testes. No final, consigo entrar na administração com o usuário que selecionei no ldap. Mas, depois de reiniciar o serviço, não consigo mais.

Não verifiquei essa tabela no Mysql, a única coisa que observei é que os parâmetros do ldap não estavam no arquivo openfire.xml.

Hoje, posso fazer uma nova instalação e verificar essas entradas na tabela e te dou um retorno.

Obrigado pela ajuda.

Abs,

Xavier

Christian,

Retificando o post acima.

Primeiro.

Na pasta openfire/bin/ , executo o comando: “./openfire stop” e depois “./openfire start”.

Abs

Xavier

Christian,

Fiz o teste que vc pediu. A tabela ofProperty está com os campos de configuração do ldap preenchidos (ldap.host, ldap.port, ldap.baseDN). Mas, quando paro e inicio o serviço do openfire, não consigo mais logar com o usuário ldap, somente com o default admin:admin.

Abs

Xavier

Bom Dia Xavier!

Desculpe pela demora em responder. XD

Eu gostariade saber como foi feita a configuração da conexão do Openfire com LDAP.

Olá Christian,

Eu que deveria me desculpar, vc está sendo muito prestativo .

Segue abaixo os prints das telas de configuração e os testes.

1.jpg

2.jpg

3.jpg

4.jpg

5.jpg

7.jpg

8.jpg

Boa Tarde Xavier!

Xavier eu que devo pedir desculpas pelo atraso, se eu respondo uma publicação e meu dever continuar ajudando até onde chega meu conhecimento.

Bom continuando…

Se não me engano você precisa preencher os campos de autenticação.

Com um usuário valido para acessar o servidor e realizar aleitura das informações.

No meu casso eu uso um usuário apenas para o Openfire, com privilégiosde administrador.

Você está se conectando a que tipo de servidor.

Um servidor de Domínio Active Directory?

Aguardando resposta

XD

Olá Christian,

Bom dia.

Vou preencher os campos de autenticação dessa vez, vamos ver no que dá.

Estamos usando o OpenLDAP.

Depois do teste, mando a resposta.

Abs

Xavier

Grande Christian,

Fiz o teste com o preenchimento da autenticação e, depois de vários testes reiniciando o serviço, finalmente deu certo, consigo entrar na administração com o usuário do LDAP e listar todos os usuários.

Muitissimo obrigado!!!

Abs

Xavier

Bom DiaXavier!

Que bom que deu tudo certo.

Qualquer coisa que precisar e só postar!

Ate mais!

XD