powered by Jive Software

Openfire + ldap

hey all i am new to this forum so i search the forum and still no help after connecting to active directory i get a window which say add users to admin the openfire so after adding some users i am unable to login to the admin console even after i restart i added the

<admin>
        ...
        <authorizedUsernames>joe, jane</authorizedUsernames>
      </admin>

to my config file and still no luck can someone help me PLEASE i am the process of updating our im server to openfire and i am testing at the time so please help me please

Did you test all your settings along the way? Did you test the users you added to admin the server at that step. It gives you the option to test the users after they are added.

To set it up again stop the openfire server. Edit the openfire.xml file in the openfire\conf directory so that the setup tag reads false. Start the server and step through the setup again and test each step.

hey man thank for the reply this is my configure file this is my test lab.

<?xml version="1.0" encoding="UTF-8"?> 9090 9091 en org.jivesoftware.database.DefaultConnectionProvider true ldap>

10.100.1.9
389
uid
cn

mail
ou=users;dc=open,dc=com
cn=administrator,ou=users,dc=open,dc=com
Password01



org.jivesoftware.openfire.ldap.LdapUserProvider

org.jivesoftware.openfire.ldap.LdapAuthProvider org.jivesoftware.openfire.ldap.LdapGroupProvider admin, administrator, keenanm, jali, com.mysql.jdbc.Driver jdbc:mysql://localhost:3306/open root Password01 select 1 true true 5 25 1.0

Re-read my previous post and answer the quests posted and/or do what i

instructed and give results.

I don’t mean to be a nebbie but thanks for the help and great website you have.@Todd Getz


okay I found out my error thanks @Todd Getz but isn’t there supposed to be a next button here or what should I do any more help

I have no idea what you are doing in clip23 the defaults have definitely been changed and those are never going to work.

thanks for the info I got the server up and running thanks for the help

please mark this as closed then. I am not sure I was much help but award points if it warrants.

I am having the exact same problem. What did you do to fix it??? I can’t get past the last settings page in the setup where you are supposed to enter an admin username. There is no Next button and it won’t accept any usernames in LDAP.

This problem is i follow the instructions in the openfire guide and the problems is

  • Base DN ↓ should be , and not ;
  • cn=Users;dc=<Your Domain>.
  • To get more specific, say your domain is
  • let me know if it works

I’m sorry, I don’t understand your response.

What I have for my base DN is this:

ou=JABC,dc=south,dc=sa,dc=gov

What is it supposed to be?

Start your own thread and give all pertenant details of your config and LDAP structure. Do not hijack other threads please.

Please mark this as closed…

Todd,

I don’t see the point in starting a brand new thread to act the exact same question. The original poster said he got it working, but never posted the solution. That doesn’t help anybody. Plus, he just posted this question about a week ago, so it hasn’t been hanging around a long time. He did write me back yesterday and attempted to help. If you insist I’ll go ahead and post a new thread…I just don’t want someone to say, “Hey! That’s already been asked over in THIS thread.”

Because with LDAP integration every single server is potentially different due to different OU structure, domain names, etc. There is no magic one answer fixes every LDAP bind issue.

Understood. I’ll post a new thread now! Thanks.