powered by Jive Software

Openfire login doesn't support on external login

i have an internal openfire messenger service setup within our intranet. yesterday my collegue tried to login this from abroad, but failed. but when he try through sparkweb, its working. i use http-bind with port 7070 on sparkweb.

I have a situation that my server certificates are disappearing after i restart the server. is it from the problem of my openfire servername and host name are different?

if i create self signed certificates, fastpath service going down and it shows as there is no java compiler.

i have attached the screenshot below.

Your server’s name is not matching its hostname (im). Are you trying to connect to it using just “im” as your Server name? How do you try to connect from abroad? Is your openfire server exposed to the internet, or have you forwarded any ports to your internal openfire server? Mght be, that certificates problems are related to this difference between server’s name and hostname.

i have created the self signed certificate and then everything seems ok. but fastpath server wend down. little later it seems working ok. I think it takes some time to reconfigure the system. earlier i did restarted the server, but this time i didn’t restart it.

testing on external spark login now. sparkweb working as usual.

the problem is because the Win 2003 server’s computer name is im, and the primary DNS suffix is domain.com.the server is exposed to the internet now. i have given the openfire server name manually, but it works over the internet for sparkweb login. the problem came into light when i tried to connect from abroad through spark client…i used FQDN as server name on spark to login.

certificates are created with same domain name.(im.domain.com). one more thing is if i restart the server, certificates disappearing.

spark logins to server now, but disconnecting with the following error on client

22-Jan-09 PM 07:34 org.jivesoftware.spark.util.log.Log error
SEVERE:
No response from the server.:
at org.jivesoftware.smackx.PrivateDataManager.getPrivateData(PrivateDataManager.ja va:209)
at org.jivesoftware.smackx.bookmark.BookmarkManager.retrieveBookmarks(BookmarkMana ger.java:219)
at org.jivesoftware.smackx.bookmark.BookmarkManager.getBookmarkedConferences(Bookm arkManager.java:91)
at org.jivesoftware.spark.ui.conferences.BookmarksUI$4.doRun(BookmarksUI.java:165)
at org.jivesoftware.spark.util.SwingTimerTask.run(SwingTimerTask.java:26)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

and fastpath also not loaded on spark. can see the user online on openfire session, but from spark, cannot see the online user.

please advice.

i have already enabled all the ports listed on the server.

Hi, Thanks for the reply.

Im unable to make the hostname and servername as same FQDN. my server’s name is (im). the domain name is domain.com , that is added as the primary DNS suffix. i gave the server name manually as im.domain.com, but the hostname generated automatically. is there any way to change it?

if i run setup again, will the data get lost? by making false on openfire.xml?

Thank you in advance.

Hostname is the name of your server’s computer (usuallu, i think so). If you are using a database (embedded or MySQL, etc.) then all settings should be preserved after running the setup again.

yea, as it takes the computer name only as hostname, im unable to make it same as server name. i have checked the database, but the hostname value isn’t stored anywhere.

I think its not affecting the creation of certificates. since I able to create certificate with the name im.domain.com.

even after having the certificates i experience login problem with spark. i have enabled tcp ports 5222, 5223, 3478, 3479, 7070. Spark logins to the server and it doesn’t enjoy a stable connection. and fastpath is not working at all on client (but works on sparkweb). I have attached the latest screenshot of the admin panel.

Thank you.