powered by Jive Software

Openfire Meetings for Pàdé ver 0.9.9 released

If you unable to use Openfire Meetings as an alternative to Zoom because it lacks few keys features like breakout meeting rooms or support for webinars, then take a look at version 0.9.9.

For other release announcements and news follow us on Twitter

1 Like

Nice work Dele :+1:
We’re loving 0.9.9 so far with 1 little frustration.

Do you have any experience with connecting to a 0.9.9 meeting using Apple iPhones or iPads? MacBooks are not a problem, but the iPhone/iPad users receive the ‘Something went wrong … reconnecting’ loop and never connect to the on-going meeting. This wasn’t a problem with 0.9.5.

I’m not a big fan of Apple, but telling these iPhone/iPad people to get real computers seems a bit rude, especially if someone (you?) knows of a solution.

Do you? Know a solution?

Apple users can download the generic Jitsi-Meet app from Apple store. Same thing for Android users.

To support mobile apps, you would need to change Openfire Meetings web folder from /ofmeet to /
In the mobile app settings, you enter the base web URL of your server - https://your_server:7443/

There is on-going work to make Jitsi-Meet work properly with Apple, but that may take a few weeks before it is available.

How is this done, because it is not possible to add a setthing to use it with a self-signed certificate, accept to trust them, not verifying them, such as configuring ofmeet, to work with the Jitsi-Meet app.
Thanks.
Best Regards

Dele: You’ve noted recently (in this thread) that there is ‘on-going work to make Jitsi-Meet work properly with Apple’, but I’d like to make sure that our recent testing results are part of that on-going work.

We’ve found that, with your suggestions of changing the Openfire Meetings web folder to ‘/’, everything works perfectly for Apple users … as long as there’s only two (2) users in the meeting. Larger numbers of Android, Linux and Windows users also work nicely, but with more that 2 users, the Apple users get blank avatars and no sound for everyone.

In the past, you’ve advised many (many,many) people that problems with 3+ users in a meeting are usually related to the Focus user. If this is part of the on-going work, we’ll look forward to another announcement. However if there is a ‘little fix’ that you can suggest, we’ll look forward to that even more.

The improvements in Pade Meetings 0.9.9 are worth waiting for.

You’ve noted recently (in this thread) that there is ‘on-going work to make Jitsi-Meet work properly with Apple

That relates specifically to the Safari web browser

I am not an Apple user and don’t have any apple hardware to test with. However, I just came off a conference call with over 10 people and one of the users had an iPad running the Jitsi mobile app. It took him a while to locate the grid (brady bunch) view and had no other issues throughout the meeting.

My server is https://pade.chat You can test if you like

Thank you Dele;

Your server works flawlessly. Ours … not so much, but only for Apple products. So we tried to recreate our server to be just like yours. Here are the steps we took:

Vanilla installation of Openfire 4.5.1 with re-initialized MySQL (maria) database

Server

Server Settings

Enabled XFF headers using default (listed) values and the current /etc/hostname

Enabled Anonymous Login (this might have been the default??)

TLS/SSL Certificates

Imported current LetEncrypt certificates

Users/Groups

added 2 new users as Adminstrators

Plugins

added Certificate Manager. Installed from files pade.jar[0.9.8 – February 22, 2020], ofmeet.jar[0.9.8 – April ??, 2020], offocus.jar[0.9.8 – February 22, 2020]

Meetings

User Interface

Context Path set to '/'

And we have the same problem with Apple products. Do you have a few minutes to review our installation and make any suggestions that might help? Thanks in advance. Sorry to be a pest, but we’d really like to be using an Openfire server just like yours

Hi,
Thanks for all the information. I have installed both plugins - Openfire Focus Provider & Openfire Meetings but I am not sure if the installation process not properly done or there’s something else. After installation it successfully created Focus & Jigasi user and Focus user appearing online but there’s no Meeting tab inside Openfire Admin console. I reinstalled it and it seems worked but everytime I am trying to access the Conference room it’s showing Failed to Connect. However Camera & Microphone settings is ok and I can hear the sound, I can also sent text chat via the web conferencing page.
I am using Openfire 4.4.2
DB: Postgress
LDAP : no
I also attached a screenshot of the plugin page,

I tried to test your server that you mentioned and it worked pretty good, screensharing also worked really good. Please share some light so I can make it work.

I am trying to create video conference for our collage study, max 8-9 member will be in the conference room, during test I only used two test account to perform conference but still no luck. So looking for help.

Read this - Openfire Meetings as an alternative to Zoom
Use this - https://github.com/igniterealtime/openfire-pade-plugin/releases/tag/v0.9.11-snapshot
And you should have this

Thank you very much. It’s working now for Two participants . When third participant join Video automatically turn off. Is there any kind of setting I need to do in systemproperties or in openfire?

Hi Dele;
I believe I’ve read and applied everything I can find from you (and others) on the problem of ‘Openfire Meetings stop with the 3rd user’.

We’ve implemented:

  • Openfire 4.5.2
  • Pade Plugin 0.9.11
  • Certificate Manager

on both an Amazon AWS server as well as a Fedora 29 virtual machine on a Fedora 29 host using KVM. We’ve configured both of these servers identically.

The Amazon server works wonderfully. The in-house server only works for 2 users; the third users disconnect sound and video everyone,

We’ve confirmed routing of a public IP address to our in-house virtual machine, with inbound DNAT and outbound SNAT. We’ve confirmed, using netcat, that UDP port 10000 and TCP port 7443 are being passed through correctly. The traffic seems to be identical (tcpdump) for bot servers. The focus user on the in-house servers starts properly and looks like this:


which is what we’re expecting.

There are several error messages being logged, but these are related to SMACK and they are identical to the error messages we see on the Amazon VM.

The only thing we can see that seems related to the videobridge, is some WARNing messages like this:
openfire-vb1.txt (3.6 KB)

But these are meaningless to us, and we can’t find anything relevant with web searching.

Can you tell me if we are missing something obvious? Or even not obvious?

And can you provide any direction for this?