powered by Jive Software

Openfire Meetings

The plan is for Openfire to support video over SIP. It is the reason why I am using the Kelpie implementation as it has the source code to do this, but I am not yet ready to make it work.

Dele, Nice Job! works flawless (to the extent i tested)

Seems like you cleaned the “moz” WebRTC calls all together…

I just want to say how outstanding this plugin is Dele, a lot of us here would be nowhere with this tech if not for your excellent skills.

Thank you again.

Just wish I could get this dang screen sharing plugin to work!

Jay

Hi Dele

I Setup OF 3.10 & Openfire meetings 0.3

only i had a problem, sip account was register but when i click on the dial…no reaction showed

For this reason, I install Openfire meetings 0.5 plugin, perhaps that work, But since then does not work.

Https://Server:7447/ofmeet

HTTP ERROR 404

Problem accessing /ofmeet. Reason:

Not Found

Powered by Jetty://

Did you solve your issue? I’m having same issue, it worked before.

Once I changed to sync with LDAP ofmeet was down. jetty is returning http 404

Hi Reza,

I had the same problem. If you’re using linux, check if more than one OF instance is running on the server (do a ps -fea | grep openfire ).

If yes, just kill all the instances and restart the Openfire.

1)Link may be made to be copied? And instead “invite” button, make “Copy” button.

  1. Picture on the Logitech C270 mirrored above vertical axis. Whats about picture mirroring functions?

Hi, my openfire meetings seems to be broken.

I can get into the meetings page and the webcam works but when i try to create it room it’s just stuck there…

what settings am I missing to get this to work? the room seems to be created in group chat but it isn’t showing up in the meetings tab and meetings summary.

Thank you! I was always getting the 404 error and I was about to give up, then I saw your suggestion. In fact, for some reason I had two openfire processes. Killed them both and restarted openfire: voilà the room opened! Now I’m psyched that it’s all working

Is there any update on Firefox support for openfire-meetings?

The plugin suggest that the fix is 977864 – Create new media streams for unannounced SSRCs received on a peer connection - but that’s been closed as wontfix.

The issue in the past was that Firefox didn’t used to support WebRTC - which it does now and has for some time.

I’m wondering if the plugin just simply redirectly all firefox traffic to the page, when in reality it would just work?

Read this

https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jits i-videobridge/

Hi Dele,

after a while I started re testing the openfire meetings unfortunately I’m having problems to make possibile the videoconf with external clients.

My configuration is this:

client 1 inside a network (behind nat)

client 2 on public network (e.g. phone with chrome)

I set up this values for the ICE Servers: {‘iceServers’:[{‘url’:‘stun:stun.l.google.com:19302’}]} and verified that UDP 19302 works.

Once I try to set up a conf i can see myself on each screen but i cannot see the other, I only see a dark screen with no audio.

As far as I remember that was the same problem I had trying to set up your jappix videochat and was resolved manually writing down the stun address.

Could this be the case? Did I put a wrong syntax for the stun value?

Regards and thanks

Giorgio

Read this

https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jits i-videobridge/

Hello,

So Firefox supports multistream and Jitsi Meet works with Firefox.

Any plans for ofmeet to work on Firefox as well ?

Thank you

Too much work and I am not a fan of FF (just kidding). At some point, we will do a code refresh with latest code from Jitsi. I just don’t know when.

i’m new on openfire meeting and spark. when i try ofmeet plugin from spark on room (conference). then chrome browser will open and connecting to my server. but why when i using ofmeet it create new user(session) ofmeet3467 and not use my real user account ?

any wrong of my configuration ?

do you have ofmeet security mode off (disabled)? If you do, then it will create an anonymous user ofmeetxxxx.

I access ofmeet from spark. This is my configuration.

Hello,

It seems there is a bug in the plugin. I cannot use the range 5000-6000 on my router (already taken), so I want to use the range 6000-7000. However, the parameter is not taken into account.

I restart Openfire (v4.0.3 on Ubuntu 16.04 x64) and the plugin, I killed all sessions, clean all data in Chromium browser (both v53 on Ubuntu 16.04 x64), then restart the browser. When I create a new session, ports are still in the range 5000-6000:

ls -Pni | grep UDP

java
7027
root 354u IPv6 205927
0t0 UDP 192.168.1.11:5030
java
7027
root 356u IPv6 205934
0t0 UDP 192.168.1.11:5031
java
7027
root 358u IPv6 202709
0t0 UDP 192.168.1.11:5032
java
7027
root 360u IPv6 202716
0t0 UDP 192.168.1.11:5033
java
7027
root 362u IPv6 206029
0t0 UDP 192.168.1.11:5034
java
7027
root 364u IPv6 206036
0t0 UDP 192.168.1.11:5035
java
7027
root 366u IPv6 206043
0t0 UDP 192.168.1.11:5036
java
7027
root 368u IPv6 206050
0t0 UDP 192.168.1.11:5037
java
7027
root 370u IPv6 204572
0t0 UDP 192.168.1.11:5038
java
7027
root 376u IPv6 204579
0t0 UDP 192.168.1.11:5039
java
7027
root 378u IPv6 205176
0t0 UDP 192.168.1.11:5040
java
7027
root 388u IPv6 205183
0t0 UDP 192.168.1.11:5041
java
7027
root 390u IPv6 202723
0t0 UDP 192.168.1.11:5042
java
7027
root 392u IPv6 206057
0t0 UDP 192.168.1.11:5043
java
7027
root 394u IPv6 206064
0t0 UDP 192.168.1.11:5044

Test perform on my local network where the range 5000-6000 works fine.