powered by Jive Software

Openfire not working with DNS

Hi

I have been trying to setup a openfire server with dns, however it seems like there is an issue I really can’t get a hold of. I use a dynu dns, and when i ping it from the same computer and other units connected mobile data instead, I get full response. The xmpp domain name and FQDN is set to the respective dns (havilaheroy.freeddns.org), but it doesn’t work.

image

Any idea what may be wrong?

Regards
Stenifan

What do mean by this in concrete? Currently, I get 148.122.187.2 for havilaheroy.freeddns.org, but there are no suitable listeners detected:

# nmap havilaheroy.freeddns.org -A
Starting Nmap 7.80 ( https://nmap.org ) at 2021-04-05 13:46 CEST
Nmap scan report for havilaheroy.freeddns.org (148.122.187.2)
Host is up (0.010s latency).
Not shown: 998 filtered ports
PORT    STATE  SERVICE    VERSION
113/tcp closed ident
179/tcp open   tcpwrapped
Device type: WAP|general purpose|storage-misc|router|specialized
Running (JUST GUESSING): Linksys embedded (89%), Linux 2.6.X (88%), HP embedded (87%), Synology embedded (86%), Tripp Lite NetOS 7.X (85%)
OS CPE: cpe:/h:linksys:befw11s4 cpe:/o:linux:linux_kernel:2.6.32 cpe:/o:linux:linux_kernel cpe:/h:hp:p2000_msa cpe:/h:synology:rt1900ac cpe:/o:tripplite:netos:7.5.2tl
Aggressive OS guesses: Linksys BEFW11S4 WAP (89%), Linux 2.6.32 (88%), HP P2000 MSA storage controller (87%), Synology RT1900ac router (86%), Tripp Lite NetOS 7.5.2tl (85%)
No exact OS matches for host (test conditions non-ideal).
Network Distance: 2 hops

TRACEROUTE (using port 80/tcp)
HOP RTT     ADDRESS
1   0.22 ms 10.69.63.1
2   0.53 ms 148.122.187.2

I mean that the dns seems to be up and running with no problem, but that i cannot login to admin console through havilaheroy.freeddns.org:9090 and neither can any users connect to openfire.

I’ve checked the ports on the computer and they are all open for openfire.

I am wondering if there are any server settings I must do in Openfire in order to make it work?

It is setup as a local database server. The lan itself is administered by a 3rd party on behalf of my company, but i don’t think they have blocked these ports out, or at least im not certain. Should i try some other generic port instead?

Alternatively, do you have any suggestions for a local dns-function?

I am setting up this server only for local use onboard the vessel i am working at, but the computer keeps changing local ip and for some reason i am not allowed to set a permanent ip-address.

This is likely a routing issue in your network.

Openfire does not have anything specific for DNS. When you set the FQDN value for Openfire, it will use that when it exposes the server address as part of an URL, for example, but that’s pretty much it.

From a client, determine what IP the DNS lookup for havilaheroy.freeddns.org resolves. Check if that corresponds with the IP address of the server. Then, check if the client computer can reach that server (eg: use ICMP ping), and then verify if it can reach the specific ports on the server (port 5222 is where the basic XMPP functionality is exposed), using something like openssl or nmap, like @gjaekel showed.

It turns out that it was a routing issue in my network, which could not be changed due to company policy… Ended up using the pcname as the local dns instead and works well now.

Thank you @guus and @gjaekel for your help.