powered by Jive Software

Openfire on centos

I have a centos 5.3 virtual machine I’m testing an openfire server on. I have tried to set it up multiple times (I installed it via the rpm) and though the web interface seems to say it has been configured properly when I click on the button to log into the admin console it takes me back to the setup wizard. I have a working java install and mysql. The first time I tried to set it up using the built in database and it didn’t seem to write the changes to that so I set up a mysql database and imported the table structure into that and it did the same thing. I manually updated a row in the database to verify that I could write to it and could but openfire wouldn’t write any of the changes made by the setup wizard.

I got mad and downloaded a windows version and had it up and running on an XP machine and using active directory in about 5 minutes.

I can’t seem to get anywhere looking through the logs as they seem VERY verbose.

What info do I need to provide to help with figuring this out.

Thanks

Has anyone used Centos for an openfire setup?

I am using Centos 5.2 and the latest openfire. I downloaded and installed the RPM yesterday. Installed the mysql-server package, made an openfire database, used the mysql script to import, set up my user/perms and ran setup and it worked.

Hi,

can Openfire write the openfire.xml file? Do you use the /etc/rc.d/init.d/ scripts to start Openfire?

If you use the /opt/openfire/… script as root then Openfire will run with the wrong file permissions.

LG

Thanks that was the ticket. I installed it via rpm and I didn’t realize that for some reason the dir that the openfire.xml lived in and also the the selfcontained openfire db’s dir were owned by root not daemon a quick chmod on both and I could use either the mysql or internal database to set it up.