powered by Jive Software

OpenFire on Synology Diskstation / DynDNS

Hi guys,

i have installed OpenFire on my Synology Diskstation DS 414. Its working fine. However, I cannot connect to it using my DynDNS that I am using for my NAS. The DynDNS works fine with all other Services on that NAS, with Ftp etc. but not with OpenFire. I already portforwarded the necessary Ports (TCP which i assume it is) on my Router.

5222

5223

5269

5275

They’re all routed through the Diskstation. But when I or someone else tries to connect with the DynDNS to my OpenFire Server, he gets “Connection refused”. Although I created Useraccounts for the Server to accept. But whatever I do, it won’t work. The DynDNS works fine for the FTP Server for example, no problems there. So it can’t be the DynDNS, and I doubt I forgot anymore ports on the Router. So I guess its something OpenFire specific. What could it be ? Any help is appreciated.

As for connection of a client, I tried with Jabber Clients such as PIDGIN and VACUUM.

I hope someone could help me with this please. Thank you very much.

Wolfseye

I can connect to it if I choose the internal LAN ip of the NAS, but not if I use the DynDNS. How comes the DynDNS works fine with the FTP Server, but not with OpenFire.

Even created SRV records with my DynDNS hoster, just to be sure I did that too. Still no change. Why does it not work with the DynDNS ? Any help is greatly appreciated.

Thank you very much.

Wolfseye

Just a few thoughts:

  1. Try using the IP directly. You mention the other DNS address work but what happens if you type in the server field IP-Address to bypass DNS.

  2. Also, open the port to temp access your admin console and try to hit that from the outside.

Try ‘telnet dyndns-name 5222’ and check the port. If this fails then it’s either your firewall or a nat/port-forwarding issue.