powered by Jive Software

Openfire on Ubuntu Server: Ports issues (not opening any)

Hello everyone,

I want to use a XMPP Server for chatting with friends, without (facebook, google etc) anyone to read along.

History (just for general Information):

I searched the web to chose an XMPP server, running on an Ubuntu to fit my privacy requirements. Openfire was the best way to do. I tested it on a nettop with Ubuntu 12.10. Everything was fine: I installed it using the .deb file and the ubuntusoftwarecenter. It started immediately. After testing the adminpanel and doing some test chats with several clients I decided to install it on my V-Server. Its a Level 2 Linux virtual-server, hosted at strato.

While I’ve installed it the first time, I saw an warning like “/var/lib/openfire Didn’t belong to the user recently created” or similar. The installation ended with “starting openfire: openfire”. But…

Problem:

The adminpanel is unreachable. I tried it with ip:9090 in firefox on my local computer, I even used w3m http://localhost:9090 in commandline.

I stopped openfire using the sudo service openfire stop command and it tells me: stopping openfire: openfire. After a restart of the hole server I started openfire again: The same result “starting openfire: openfire”. I asked me if the process maybe isn’t running, so I used "top | grep ‘openfire’ " and off cause It appears every few seconds.

Further Facts:

I use Plesk Panel for the general settings (firewall (all Ports concerning openfire are open: 5222, 5223, 9090, 9091, 7777) and webspaces).

I use the apache2 webserver with virtual hosts, to manage the 4 domains pointing to the server.

Java is in Version oracle-7 installed as in this guide described ( http://www.thefanclub.co.za/how-to/how-setup-instant-messaging-server-using-open fire-ubuntu-1204 ).

I installed openfire using “sudo dpkg -i openfire_3.8.1_all.deb”

Can anyone help me, please? Are there maybe some dependencies I don’t fulfil?

There may be error logs which contain the reason why it fails. Maybe the JVM can not allocate memory.

The Problem is: all logs are empty. I took care that they belong to the openfire user (chown on all locations openfire uses), but still all logs stay empty. I even modified the /etc/init.d/openfire script to show more details (using the --verbose instead of the --quiet option with the start-stop-deamon) and echoed the JVM location and the Deamon_Opts to make sure that there’s no problem. What worries me the most is the running process: It installs without errors, its starts without errors it even runs without errors, but Port 9090 didn’t show up in netstat -l and is not accessible with any browser. If there’s another service using the port 9090, there would be an indication in netstat -l, or am I wrong?

The Problem is solved, but I can’t say how.

My hoster did some kernelupdates on my Virtual server and after these it worked fine. This installation guide is working: http://community.igniterealtime.org/thread/48282 .