Openfire on Windows Server x64 with Java8 64-bit - more guidance needed!

Hi folks!

I’ve been a long time around reading posts of the community an using openfire as a public xmpp server. First on linux based machines, nowadays running windows server for smoother administration of all services :wink:

However i have to set up a brand new (clean install) windows server system an get openfire up an running. I dont’ want to use the the “recommended” .exe-file because it comes with included JRE 32bit. I want to setup openfire using JDK or JRE 8 64-bit. But i’m running into some trouble here.

What i’ve done so far after installing windows:

Downloaded the Java SE Runtime Environment 8 Windows x64 .exe installer and run it. (jre-8u31-windows-x64.exe). So for me the necessary jvm is installed on that machine. Proofe here:

Now i’ve downloaded the latest (Does not include Java JRE) and unpacked it. If i try to fire up openfire using the openfire.exe in the /bin directory i get the error message saying that no JVM could be found on the system and that i have to define EXE4J_JAVA_HOME to a installed 32bit JDK or JRE.

Ok, first of all openfire didn’t recognise my installed JRE 1.8.0_31 at C:\Program Files\Java\jre1.8.0_31\bin\javaw.exe but it also claims it only will work with a 32bit version of java. So is this true?!

What i’ve tried further on:

Since i’m using the file, there is no “jre” folder within the openfire folder. So i created one and copied the contents of the downloaded jre1.8.0_31 in it. (I downloaded jre-8u31-windows-x64.tar.gz and unpacked it into the jre folder within openfire)

Next try firing up openfire.exe i get the error message, that the a JVM is found but it is damaged :frowning:

Tried the step with manually download the 64bit jre and copying it into the opfnire folder a few times but still get the same error.

Even using these hacked files to get openfire running with java x64 didn’t work out.

How to get openfire running under a windows x64 operating system using JRE or JDK 8 64-bit? For me, more guidance is needed here!

It seems someone managed to get Openfire using x64 Java on Windows here Openfire 64 bit default installer (w/JRE8-64 bit includes) Dele suggested a link with 64-bit binaries for Windows (3d party).