Openfire on Windows x64 with Java x64

created exe4j service for Windows x64

and compiled Norman Rasmussen’s NTLM dll on x64

By the way you must have 64bit Java installed on you system

(this version of openfire-service.exe didn’t use openfire\jre folder)


Are these drop-in replacements for the files in Openfire\bin? What version(s) of Openfire will these work with?

yes it is a replacement of openfire-service.exe

I’am tested it on OpenFire 3.4.1

It should works on all versions of OpenFire,


openfire-service.exe is enough.

What did you means “sistem hanged” ?

Sorry for a quite long delay.,

One thing that must always be remember with Java, the difference between 32bit and 64bit is that more calculations can be done, BUT, it takes almost twice as long as the 64bit to “initiate”.

Just a small fact i read from Sun

Good news!

I recompiled openfire-service.exe so it now works not only 30minutes but unlimited time.

Elgreco, thanks for yours bug report.


do we know if this works on version 3.7.0 as I have this on a 64-Bit box but can only use a 1gb Java Heap and would like to give it some more juice. any ideas on if this is possible etc.

thank you

3.7.0 is rather unstable now, so we haven’t yet using it on production.

We tested it(with x64) just after 3.7.0 release date it works ok (but there are other bugs in 3.7.0 so we downgraded it)

Fair enough we have been running it for a few months and not hit any problems, but is running in 32-bit “mode” so only as a 1gb heap, which is ok but the % used is getting higher so am trying to find ways of making it bigger as using a 32-bit version of java etc. i cant go bigger i dont think… unless there is some clever stuff somone knows about. I’m a bit of a java rookie…

Main bugs in 3.7.0 are:

-s2s connection problems with other servers like Ejabberd

-c2s connection problems (disconnection after some cyrillic messages)

Hi, 3.8.0 broke compatibility with the 64-bit service launcher. I tried to compile a new one and it works but after 30 minutes it stops, which I found out is because I have no license for exe4j.

Hi, where 3.8.1 x64?

Windows 7, 64bit, JDK 7(64bit). openfire 3.9.1

Facing 2 issues.

  1. We have copy pasted the JDK to some other folder as C:\program files\java7\jdk1.7.0_55. Since we have different versions of java & 32/64 bits of installed in system due to different application request. How to point openfire-service.exe to pick particular JDK?

  2. What are the 64bit corresponding ‘openfire.exe’ and ‘openfired.exe’?

Wow, what a plus!!!

Working fine with the latest Openfire 3.10 beta (not nightly), Spark 668 and Java 8 b40. Running on Win2k8 Server x64 !!!

I don’t understand why at this time, there isn’t, at least on Openfire, a pure x64 build…

Tried with the latest 8.10 RC version, but the service wont start… any idea??

Hello. After switching to Java x64 , not the logs are written to a folder

Windows 2012 R2

Openfire 3.9.3

Java 8.66

x64 modules no more working with 4.0.4 ? It seems like that.

And at the end of 2016 mainstreem OF still x32. Whyyyyyyyy? oO

All of the mainstreem server platforms x64 already. That still prevents to do mainstreem x64 OF?

x64 CPU arhitecture (AMD64, EM64T) at 2016 year turned more than 10 years. This is the age.

I must say that for me worked the opposite.

A few versions back, x64 workaround stopped working. But today after installing new openfire version 4.04, I tried to install the x64 workaround.

I just moved the 3 files to another directory and put the ones from this thread. Run openfire service and everything works fine!!! x64 again!!!

Where can I find a 64-bit library for transparent authorization? (Norman Rasmussen’s NTLM dll on x64)

Checking my new account was very long. During this time I found a working link ( Maybe it will help someone