powered by Jive Software

Openfire Pàdé 1.1.1 released!

The Ignite Realtime community is happy to announce the availability of Openfire Pàdé v1.1.1.


This version upgrades ofmeet to Jitsi Videobridge version 2.x and fixes the audio and video issue with Chrome 87. It also fixes the compatibility issues with Firefox and the Jitsi mobile applications on IOS and Android. For more details on what has changed, see the release notes.

For a desktop experience, you install the Pàdé browser extension from the Google Chrome app store or Microsoft Edge app store. For a web or progressive web app experience, you install the Openfire plugins and access (by default: https://your_server:7443/pade) from your favorite desktop or mobile web browser

UPDATE version 1.1.2 is now available

For other release announcements and news follow us on Twitter

1 Like

Hi Dele!

Unfortunately; even with 1.1.1 - i am still unable to initiate an online session for the Focus/JVB generated users. Joining/creating rooms ends up crashing. Any idea what i am doing wrong?

Thank you!


2020-11-24T22:00:25.059Z [JitsiMeetJS.js] : UnhandledError: Focus error, retry after 2000 Script: null Line: null Column: null StackTrace: l.prototype._allocateConferenceFocusError@
l.prototype.allocateConferenceFocus/</<@

Nothing will work if jvb and focus users are not online and talking to each other from the ofmeet chat room. Fix that first and work your way from there

Hi Dele,

The Focus & JVB users are supposed to be “online” after JAR installation? Is there a specific configuration i need to perform besides setting up the ofmeet global conference? both users still show offline.

Thank you,
Sam.

I believe this is the issue:
org.jivesoftware.openfire.plugin.ofmeet.JitsiJicofoWrapper - Caused by: java.net.UnknownHostException

The above was not relevant in version 1.0.x

I had similiar issue because i was using main domain let say example.com for hosting a static website and I installed openfire in another vps and point it with subdomain. let say openfire.example.com. so when I pointed main domain with the vps where openfire was installed then it start working and I think you have also that issue.

Make sure the name reported by Openfire as your hostname is a fully qualified domain name. In other words, you can ping it and get a valid IP address

image

Hi Dele,

That did the trick. Since my instance is hosted on a VPS without a valid domain name - i had to set the FQDN to the static IP.

The issue i am still having is 3+ users on any browser still not working (assuming WebSockets being blocked).

ofmeet room is set up in the global conference with focus/JVB users joined, valid permissions for focus/JVB users set as well + component session shows focus user online.

Still currently looking through the log file - nothing blatantly evident that i see.

Any ideas?

That should not happen as I implemented a websocket reverse proxy that proxies from the standard 7443 port to the JVB websocket port on 8080. I run my pade.chat service on a Docker instance that is more restrictive than a VPS

Check the sip-communicator.properties file generated from your settings made in the networking admin web page.

I have the same problem Focus & JVB not online, any help how to configure online?

I have been unable to get the focus user or the JVB user to come online with versions 1.1.3 and versions 1.1.1. However if I go back to version 1.0.2, the focus user starts working again (focus user is online). I’m not sure what changed in the 1.1.X versions, but there is something there that is not working with my configuration. If anyone has any suggestions, I’d love to hear them. It might be because I’m running it on a windows machine. Not that this is going to change anything, but this server is set up with a FQDN and a working ssl certificate. I can confirm that this server runs 1.0.2 flawlessly.

Hi Clark,

I had the same issues with v1.1x. The reasoning was the FQDN I had configured with my instance (also running on a Windows environment). My instance was on the cloud, with no reverse DNS and no SSL. the way I got it working was to rerun the setup and change my FQDN to my cloud instance public IP.

That did the trick for me.

Thanks,
Sam.

Sam,
Thank you for your reply. That helps and gives me some things to think about. I’m running mine on a physical server with reverse dns configured. I appreciate you letting me know what worked for you and I’ll keep working on it. Worst case scenario, I go back to 1.0.2.
Thanks,
Clark

Hi Clark,

No problem at all! Just a reminder, version 1.0.2 will only work on Chromium based browsers prior to v87.x.

Good luck!
Sam.

Without seeing your log file errors, I can only guess that it is not working because Openfire was installed on “Program Files/Openfire” folder. This is an issue for all versions 1.1.x because of the embedded space

Dele,
That has to be it. I’m certain that it was installed in the program files folder. Thank you for letting me know.
Clark

I’m happy to report back that I was able to install 1.2.0 today once I relocated openfire from the program folders\openfire directory and to another directory. I really appreciate the help!
Thanks,
Clark