powered by Jive Software

Openfire Pàdé 1.2.0 released!

Update: Version 1.2.2 is now available

The Ignite Realtime community announces the availability of Openfire Pàdé v1.2.0. This version returns Openfire Meetings (ofmeet) back to a single plugin with wrappers for all three Jitsi components (jvb, jicofo and jigasi). See the change-log for details

Support has been added to enable audio conferences in FreeSWITCH to be linked to Jitsi video conferences with the same names when the focus user joins/leaves the associated Openfire group-chats. You can configure your FreeSWITCH dialplan to allow SIP devices and phones to dial internal or external telephone numbers to join these bridged conferences.

Openfire Pade is a community effort and would not have got this far without the generous contributions of members. We say thank you to Guido Jäkel, Claude Stabile, ayushbhat and other contributors

For other release announcements and news follow us on Twitter


Is there an extra installation step required??

We’ve been happily using Openfire Pade 1.1.2 with many users and Jitsi users. Thank you for the great work on this.

Last weekend we began experimenting with Openfire Pade 1.2.0 and 1.2.1. To install, we cleared 1.1.2 by:

  • remove pade
  • remove jitsi videobridge
  • remove ofmeet
  • delete focus user
  • delete jvb user
  • restart openfire

and then with the 1.2.1 components:

  • install pade
  • install ofmeet
  • confirm the existence of the focus user
  • confirm the existence of the jvb user
  • restart openfire

After this, we can start meetings … BUT ONLY WITH 2 USERS. Adding the 3rd user makes all video images revert to avatars.

In the past, this has indicated a need for the focus user, however this user exists. It feels like there is an extra step required for 1.2.1, but I can’t see what that would be.

If we reverse the steps and re-install Openfire Pade 1.1.2 everything works again.

Do you have any suggestions??

Thanks in advance.

The difference between 1.1 and 1.2 is the merging of the jicofo plugin and fixing some critical errors on video switching and quality. I suggest you look at the changelog and follow the issue conversations links on GitHub. There are some new settings that might affect you like the use of websockets or data channels in Jitsi Meet

I would suggest you check your log files and settings. Are you running on Windows or Linux? What does you summary page look like. Are all icons green ticks or have you got a red cross somewhere?

Thank you (again) Dele;

The Summary Page was all green checks
The error log was empty
The info log contained this reference:
type='error'><error type='cancel'><internal-server-error xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/><text xmlns='urn:ietf:params:xml:ns:xmpp-stanzas' xml:lang='en'>minPort (-1) and maxPort (-1) should be integers between 1024 and 65535.</text></error></iq>

and the Github issues dialog from: https://github.com/igniterealtime/openfire-pade-plugin/issues/113

directed me to Meetings > Networking

where I made the change suggested.

So although it seemed a bit complicated, your direction was exactly correct. :grinning:

Thank you again.

I have sucessfully deployed version 1.2.1 on the following servers


You can use freely these server to experiment latest 1.2.1 release. You can also create your Padé XMPP account, ideally on https://www.free-solutions.org/pade

First impression is very positive as Video quality is much more better especially with Firefox. There is also a great speed improvement when many people are joining.
Quality issues are fixed.
Thanks very much @Dele_Olajide for terrific efforts done and fixing all issues. We
continue using and testing your very latest code on these sites and report findings

Many thanks to all contributors and enthousiasts with Padé Openfire. It is now a very unique package that cover a very large scope of online requirements.

CONGRATS to everybody for that !!!

I have updated all Free-Solutions sites to Padé & Ofmeet 1.2.2