powered by Jive Software

Openfire Properties

all we can do is to file this JM-1533 and to wait till someone look into this

thanks . I just wanted to know if it was working for other people but seems like no one has been using it .

Hello there. Not really sure if this is the right place to post regarding an issue, but xmpp.muc.tasks.log.timeout is not working on version 3.6.4.The default value of 300000 is too high for me, so I set it to 2500 (2,5s) but even after a restart of the openfire program it does not care about it. I am using Gentoo and java version "1.6.0_02"
Java™ SE Runtime Environment (build 1.6.0_02-b05)
Java HotSpot™ Client VM (build 1.6.0_02-b05, mixed mode)

I am using MySQL as database and have verified that entries are indeed logged to ofMucConversationLog, just not in the timely manner as I want.

Well, maybe there are more system properities not working properly, but only the developers can answer that. Maybe you should also ask on the forums. Maybe this setting cant be set lower than 300000.

Imo, none of these timeout properties seem to be working properly, that is why I resorted to writing my own custom servlets to take care of timeouts etc…

Please tell me more about this servlet.

U can expose a servlet via the openfire plugin and do whatever u want with openfire. I.e i am currently facing issues whereby the users never get kicked out. So I wrote a plugin that checks the sessions of everyone active and see how long they have been active for. I.e if system.currenmil - lastactive > i.e 120000 (2mins) , then i close the session. Try to look on the forum or google. There should be something there.

Best thing to do is grab a copy of the source code from svn, search the code yourself for the property you want to use and see what the actual code is doing with it. It’s usually pretty straightforward and compiling your own version of Openfire is super super easy on a linux box.

not so hard on a winbox either i’m not a coder and i manage to compile spark/openfire with Netbeans

Lol for the icing on cake,

I have to mention that i am using mac osx to compile openfire and this is also dead easy.

I added a bunch of xmpp.pubsub.* properties. I have only used **xmpp.pubsub.multiple-subscriptions **and xmpp.pubsub.sysadmin.jid myself and can confirm that they work.

how can I change the users session timeout ?? (logged in the server)

because the xmpp.server.session.timeout is TODO

and I used it and it doesnt do anything!

TODO means it’s not yet implemented, so it doesnt work obviously. And i think this property is for server to server connection. What do you ant to achieve with such option? Maybe you want idle clients to be logged off? Then xmpp.idle is the option you need, but it seems it doesnt work (i’ve filed a bug report) or works only sometimes.

lol any idea when those subtle issues will b fixed. they are pretty important imo. i worked around some ofthem but still pretty annoying

Unless someone provides patches.

The granularity of **xmpp.pubsub.multiple-subscriptions **is the whole Openfire. Is there any plan to implement a more finer-grained control of multi-subscribe feature as described in XEP-0060, Section 6.1.6?

In the code i noticed the property

xmpp.pep.enabled

for people looking to turn off XEP-0163

What is the default value for the property xmpp.httpbind.client.requests.wait ?

Does anyone know if a restart is required after changing the mail.smtp.host value? My value was very wrong, and after correcting it my problems still persist.

Thanks

Can java system properties can be set via openfire web console --> system properties ?

like below ones

Property name Value

com.sun.jndi.ldap.connect.timeout      5000

etc.