Openfire, Red5 Plugin, Mac OSX 10.5.5 - install / setup help


I recently installed Openfire and the Red5 plugin on my MAC (OSX 10.5.5). The installation of Openfire went well, but I can’t seem to get the Red5 plugin working. On my Windows machine (ew, yuck!) everything worked ok, but no luck with my MAC. Eventually, I will move everything to my Centos5 server, but for development, I’d like to get it all going on the MAC first.

Any ideas on how to get this working is much appreciated. Here’s the problem:

After installing Openfire, I copied the Red5.war file to my /usr/local/openfire/plugins directory. After doing so, I restarted Openfire, and the Red5 directory was then created in the plugins directory. The next step was to make sure HTTP binding was enabled (which it is on 7070). When I attempt to navigate to the location:


I get the error below:




Just for fun, I tried navigating to the readme.html page as well as the red5.html page - all of them resulted in a similar error.

Also, the Red5 plugin does not appear as an install plugin in the Admin panel, and the Red5 settings page is also missing. I’ve tried everything I know to get this working, but apparently, I don’t know enough.

Thanks a bunch!!!

Check your info.log, did you get these messages:

2008.10.18 23:43:06 Initializing red5 Plugin
2008.10.18 23:43:06 Registering red5 as a component
2008.10.18 23:43:06 Starting PacketHandler
2008.10.18 23:43:06 Creating web service red5

Check your stdout.log, did you get these messages:

Red5SIP starting in scope sip C:\Program Files\Openfire\bin
Red5SIP using RTP port range 3000-3029, using SIP port range 5070-5099

Thanks for responding.

I do not see anything like you mentioned in my info.log file. Below is what I see:

2008.10.20 09:36:45 Publish-Subscribe domain: pubsub.localhost
2008.10.20 09:36:45 Multi User Chat domain: conference.localhost
2008.10.20 09:36:46 Openfire 3.6.0 [Oct 20, 2008 9:36:46 AM]
2008.10.20 09:36:48 Admin console listening at:
2008.10.20 09:36:48 Started server (unencrypted) socket on port: 5269
2008.10.20 09:36:48 Started plain (unencrypted) socket on port: 5222
2008.10.20 09:36:48 Started SSL (encrypted) socket on port: 5223

It did, however, create the red5 directory in the pluggins directory.

Also, I can’t find the stdout.log file. The closest I found was launchd.stdout, and this is what was in there:

Mon Oct 20 09:36:42 EDT 2008
Starting Openfire
Waiting for
Openfire 3.6.0 [Oct 20, 2008 9:36:46 AM]
Admin console listening at:

I am using the latest (?) version of the plugin: which I downloaded this morning. This version seems to be working with my Windows servers (except I seem to be getting errors w. SparkWeb - see below). But, sadly, not with my MAC server.

Any ideas??

Windows SparkWeb errors:

On Load, I get this error:

TypeError: Error #1009: Cannot access a property or method of a null object reference.
at com.jivesoftware.spark::StatusBox/init()
at com.jivesoftware.spark::StatusBox/___StatusBox_Canvas1_creationComplete()
at mx.core::UIComponent/dispatchEvent()
at mx.core::UIComponent/set initialized()
at mx.managers::LayoutManager/doPhasedInstantiation()
at Function/
at mx.core::UIComponent/callLaterDispatcher2()
at mx.core::UIComponent/callLaterDispatcher()

While using SparkWeb, I get this error:

ArgumentError: Error #2025: The supplied DisplayObject must be a child of the caller.
at flash.display::Loader/_load()
at flash.display::Loader/load()
at com.jivesoftware.spark::ScreenWindow$/timerHandler()
at flash.utils::Timer/_timerDispatch()
at flash.utils::Timer/tick()

I have the same issue on a debian installation. Downloaded, uploaded .war file to /opt/openfire/plugins. After a couple of minutes, it had created a red5 folder there as well with the web files. It wasn’t recognized as a plugin, though - no red5 section under server, not listed in plugins, nothing showing up in logs, and I couldn’t access the web page, just a 404 error from the jetty server.

I rebooted the server and no sign of red5 loading then, either. No entries in info.log or stdoutt.log.

Openfire 3.6.1 on debian 4.

I saw another installation note that said red5 might not run under any Java older than Java 6 (I was on 5). I upgraded my server to Java 6 and red5 plugin appeared on reboot. I think that portion of my problems is solved.

I have the exact same issue, I’m desperate to get it resolved.

I have upgraded Java on OSX Server 10.5.5 to 1.6 and the plugin still does not appear.

I have made Java 1.6 my default JVM. >>Applications>>Utilities>>Java>> Java Preferences

Is there any further config that I need to apply.

Red5 just doesn’t appear under the admin interface…

Can any of the developers help with this?

I’ve managed it - its a real hack - but works…

Hey, thanks for the reply. I was going to check out your link, but it appears to be dead. Will you please repost it. Thanks!!

Try this -