powered by Jive Software

Openfire Server Configurations Resets Automatically

Issue: openfire server automatically resets to configuration state after running for few days. I.e. when i open the Admin Console, it starts asking for configuration from the begging (starting from the language, server config etc) and if I proceed, it would say that it cannot write to conf/openfire.xml

This happens countless times…i had to purge the installation and reinstall openfire to get it start again. Granting write permission /usr/share/openfire/conf does not solve the issue either. The mystery is why it happens suddenly?

System:
OS: Ubuntu 16.04.6 LTS
Openfire server: 4.3.2
Java: openjdk version “1.8.0_191”

Can anyone advise me with the cause of this issue?

Many thanks
Lee

How do you install and run it?

I install the deb package

dpkg -i openfire.x.x.x

You do this with sudo? Is it showing any error during the install? It should create openfire user and run Openfire with it. Only that user has write access to config files, etc. Do you let it run automatically or run manually?

Yes…i ran it as sudo. And it works fines for few days without persion problem…initially permision set was ok. But suddenly gets the permission changed.

I let it set automatically at the installation

Well, i don’t have a way to make it run for a few days. But i have just installed 16.04.6 into a virtual machine. Minimal install. Then installed OpenJDK 1.8.0_191. Downloaded Openfire 4.3.2 deb and installed it. Connected to this VM from my host with http://ip_address:9090 and finished the setup (embedded database, default - no AD integration). Created a user and connected with that user in Gajim from my host. Tried to reboot the server. Gajim reconnected successfully after the server reboot.

So far everything seems fine. Will try to let it run longer and reboot from time to time to see if it fails at some point. Maybe you have installed some system updates?

1 Like

@wroot…thanks so much for the effort. Really appreciate it. Only one change though. Mine is AD integrated.

In my case also, it has been running for few days without being reset, but I am sure it will reset one point in time.

Cheers

Maybe something changes on AD side then. Though it shouldn’t present a setup page again in that case. So it looks more like something with permissions.

Yeah…i was thinking the same. Because, openfire does not use AD logins to write to files, i could not relate the issue with the AD. however, I ll try to make the openfire server a member of AD and create a user account openfire and add it to openfire local group…that’s the only solution i can think of trying.

BTW…thanks so much for your time and effort to give me a solution…i really appreciate it.

Not a problem :slight_smile: I’m currently doing a lot of testing on AWS with various OSs and Openfire anyway. So it was just another flavor of Server version to test, didn’t take much time to setup.

This is a clear indication of a file permission issue. If things are not saved in openfire.xml, then it’s likely that, as you have noticed, Openfire would eventually reset itself to ‘setup’ mode.

Try to figure out what user is used to run the Openfire (java) process. This user should have write access to that file.

Openfire deb installer creates user openfire:openfire and runs the daemon with it (/etc/inid.d/openfire). You can check that in Admin Console on the first page, it shows the owner of the process.

yeah…it is openfire and as of now it has

lrwxrwxrwx 1 openfire openfire 13 Jan 31 22:59 conf -> /etc/openfire