Openfire service installed, Won't work on logout, works through GUI only

So I’ve recently been given the chance to build a server specifically for our building access and to host our Chat services through Openfire. The “server” runs Windows 8.1 Pro (building access program is compatible with Windows 8.1, and Windows 2012 server is too large of a cost to justify for a small business)

Here’s the issue, If I have installed and run Openfire via the gui, users are able to utilize spark till I log out of the “server”. I installed the service as an admin in cmd prompt with the “openfire-service.exe /install” and started it without the gui running. I have done this on the local user I have on the server and from my admin. It seems like it installs fine, and is in the services.msc, but I can’t connect even if the service is running.

TL;DR I run gui, users can chat. Service installs, but can’t connect.

Hard to tell what is going on exactly, but it may be a permission issue. You can try installing it to C:\Openfire and see if service works then.

It was installed at the root directory (i.e. C:) and still had the same issue.

NOTE: I do have Openfire running on another server, I’ve specified in the server as follows:* *and also as just *server *

I’m also logged into the local admin on the computer installed at the root drive. Service shows up in services.msc and running.

I just can’t connect if I have the service installed and running. Only from the GUI, which means if I logout then it all stops.

I have just tried to install it on Win8.1Pro x64 virtual machine. Installed into C:\Openfire (installer launched via Run as administrator). Then launched Command Prompt (Admin) and installed the service. Started the service. Launched IE and went to and went through setup. Logged as admin to admin console. Launched Spark on the same machine and logged in as admin user in Spark. Works for me.

The only thing I did differently is that I didn’t install the service before I did the setup…I’ll try that.

EDIT: No dice. I’m the in the local account, everything is run as admin. Service states it’s running in Openfire. Can’t get to the webgui unless it’s though the openfire server gui…

It shouldn’t matter how you run the setup.

The difference might be, that i have done this with an MS account, not a local account.

Ok, just did it again.

Created a local user. Enabled Administrator account. Logged out. Logged in with local account. Ran Openfire 4.0.0 setup via Run as administrator and provided local Administrator’s credentials. Launched Command Prompt (Admin) and provided local Administrator’s credentials. This should work when going through setup with a graphical launcher. I’m just skipping unnecessary step if you are still going to use it as a service Launched IE and went through setup again. Was able to login with a Spark on the same machine.

Would just do everything with a local Administrator account to keep it simple.

I used Revo to uninstall it and went back through for the 6th time. Not sure what changed this time, guess lucky number 6. Thanks for the assistance. I’m not sure if the installing the service before I went into the web gui setup did it.

I then had troubles with the firewall blocking it. Didn’t have that before but an easy fix as it’s an inward facing machine. I’ll configure that part later.