Openfire Service Restart - Setup not saving

I have a VPS running Centos.

I have succesfully installed and setup Openfire 3.10.2.
I was able to log in. create users and connect… however as soon as the openfire service is restarted :9090 goes back to the setup and connection via xmpp client doesn’t work. Its like a fresh install.

I edited the openfire.xml file and changed True to false

This issue still occurs and still reverts to setup.


How did you install Openfire? Via the RPM? Does the daemon user own /opt/openfire and all files/folders underneath that path? How are you starting Openfire, via the init script?

Yes installed via RPM.
Unsure about daemon user ownership (i’m still quite new to CLI and SSH).

Yes openfire is in /opt/openfire/

Yes the service is started with " /etc/init.d/openfire start" exactly as linux documentation shows.

Just checked the owner of /opt/openfire/conf…

root@dev [/opt/openfire/conf]# ls -lh

total 44K

drwxr-xr-x 2 daemon daemon 4.0K Sep 14 15:52 ./

drwxr-x— 11 daemon daemon 4.0K Sep 14 15:26 …/

-rw-r–r-- 1 daemon daemon 18K Sep 14 15:52 available-plugins.xml

-rw-r–r-- 1 daemon daemon 1.6K Jun 22 12:36

-rw-r–r-- 1 root root 2.2K Sep 14 15:52 openfire.xml

-rw-r–r-- 1 root root 2.9K Aug 28 16:06 security.xml

-rw-r–r-- 1 daemon daemon 11 Sep 14 15:52 server-update.xml

Should root:root realy be the user and group of openfire.xml?

as a test i changed ownership of those two files anyway and went through setup again… setup was saved.

Then i restarted the service.

Back to setup. GRRR!

No, everything in /opt/openfire should be owned by a user actually running it, i presume daemon in your case. As it can’t change openfire.xml and mark than setup was completed, you get repeated setup.

chown -R daemon:daemon /opt/openfire

I originally just did:
chown daemon:daemon openfire.xml

chown daemon:daemon security.xml

That didn’t work.

after running yours, its all sorted. I suppose i didn’t check if /opt/openfire was owned by daemon… just the files within.

Either way, thank you.

I have openfire 3.10.2 after first installed it can start and Logged in as admin.

but my problem is unicode in thai language appear ???.

So I re-setup again with Database URL: jdbc:mysql://localhost:3306/openfire?rewriteBatchedStatements=true&useUnicode=t rue&characterEncoding=UTF-8&characterSetResults=UTF-8

after that I can solved unicode problem

BUT every time i restart my machine, openfire not saving and alway display setup page.

I choose re-setup every time restart because it better than unicode ??? problem.

also I did chown command on above and still not saving.

thank you.