powered by Jive Software

Openfire setup HTTP ERROR 500

I’m setting up an Openfire server for the first time. I’m using a new MySQL database and will be connecting Openfire to our AD to pull user info.

My problem occurs at Step 3 in the Profile Settings section of the setup. I leave the setting on this screen as the defaults and hit Save & Continue then get the following error page:

HTTP ERROR 500

Problem accessing /setup/setup-admin-settings.jsp. Reason:

Server Error

Caused by:

java.lang.NullPointerException
at org.jivesoftware.openfire.admin.setup.setup_002dadmin_002dsettings_jsp._jspService(setup_002dadmin_002dsettings_jsp.java:99)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:547)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1359)
at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1330)
at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:74)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1330)
at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:50)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1330)
at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:78)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1330)
at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:164)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1330)
at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:478)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:520)
at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:227)
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:941)
at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:409)
at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:186)
at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:875)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:110)
at org.eclipse.jetty.server.Server.handle(Server.java:349)
at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:441)
at org.eclipse.jetty.server.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:919)
at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:582)
at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:218)
at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:51)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:586)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:44)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:598)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:533)
at java.lang.Thread.run(Unknown Source)

Powered by Jetty://

Any suggestions are appreciated.

Well I found that it doesn’t give the error and moves on to the next section if I’m using IE instead of Firefox. So there’s that.

I’m now running into a new problem however, At the Administrator Account screen, there’s no Save & Continue button. Will look around on the forums about this for a while.

Never found an answer for the missing button; however, a work around was to Add the administrator like normal, then click on the section heading in the left column for Administrator Account. That took me to the screen where I would add a non LDAP user manually as an admin. I just skipped that step and completed from there.

After that however, the page never loaded what to do to complete the install, it sat on a “loading” style page.

After an hour I came back and just closed that as it wasn’t doing anything.

The server GUI launched fine. The admin panel no longer takes me to the setup page but to the server management page, which is good.

I manually installed Spark on a test terminal and (after manually adding 5222 to the server’s firewall exception list) was able to successfully connect to the server.

I had the problem in Chrome. Switched to Firefox allowed me to get past the Error 500

Then couldn’t add admin account in the setup interface and re-run the setup using Internet Explorer

Apologies for re-opening many old conversations but…
This comes up in google search results and this error continues to show up. There is a solution posted on one of the results but people keep hitting the same thing.

The solution is to go back to the server page. Either the XMPP Domain Name or the FQDN is wrong. Mine had defaulted to machine.local_lan.int for both. It should have been :
XMPP Domain: local_lan.int
XMPP FQDN: machine.local_lan.int
Someone could put a try/catch around the line generating this and inform people that it is their server settings. Instead it suggests that this is caused by a cookie problem and to try clearing history or using an incognito tab.