powered by Jive Software

Openfire setup problem adding Administrator

Hello,

I have a brand new installation of Openfire 3.6.3 on Windows Server 2003. I having a problem with the setup wizard. I am trying to connect this to a SunOne LDAP server, located on the same server as Openfire. My ou=JABC and my domain name is dc=south,dc=sa,dc=gov

I cannot post the code as I am working in a secure environment.

On the Connection Settings page:

BaseDN: ou=JABC,dc=south,dc=sa,dc=gov

Administrator DN: cn=Directory Administrator

On the Administrator Account page:

Choose one or more users from your LDAP directory to be administrator by entering their usernames.

Add Administrator: gizmo_admin

Then I click the Add button and the page comes back and says: “No username was provided or the specified username was not found.”

It does not matter which admin username I add, it won’t accept any of them.

What am I doing wrong?

Gizmo

My guess here is that your AdminDN is not correct if there are spaces in the name. You need to wrap it in quotes or choose an adminDN with no spaces. Additionally it should be a full DN like cn=username,ou=JABC,dc=south,dc=sa,dc=gov.

Todd,

My problem is resolved; although my AdministratorDN still has spaces in it and I made no changes to the BaseDN. This is what I did:

On the Connection Settings page:

BaseDN: ou=JABC,dc=south,dc=sa,dc=gov

AdministratorDN: cn=Directory Manager

On the User Mapping page:

In “Advanced Settings” link in the “Search Field” text box, I entered: (objectClass=organizationalPerson)

On the Group Mapping page:

In the “Member” text box, I entered: uniquemember

In the “Advanced Settings” link in the “Group Filter” text box, I entered: (objectClass=groupOfUniqueNames)

I believe that the way my LDAP is configured to use “Additional Indexes”, I could not originally find the usernames the way I was running through the setup before.

Problem solved!

Gizmo