powered by Jive Software

Openfire Spark admin console not displaying


#1

When launching Openfire on our dedicated VM I get no errors, Spark will let everyone in the company sign in and there’s no issues with AD connection or anything like that. I am, however, unable to get the admin page to come up either from that VM or from any other machine where I used to access it from. We’re set to ports 9090 and 9091 but I’m getting a page cannot be displayed.
I have checked the firewall on the VM and there’s nothing else using 9090 or 9091 and there’s nothing being blocked on those ports. localhost:9090 and 127.0.0.1:9090 give page cannot be displayed in IE and Firefox, I get the same thing when using the name of the machine (openfire:9090) from my desktop elsewhere in the building.
There don’t seem to be any errors on the openfire console when launching and to my knowledge no changes made to the machine since I last looked at the admin page. Can anyone suggest some steps to further troubleshoot this issue? Thanks!

Openfire 4.2.3 [Nov 2, 2018 7:08:12 AM]
Successfully loaded plugin ‘admin’.
Successfully loaded plugin ‘broadcast’.
Successfully loaded plugin ‘motd’.
Successfully loaded plugin ‘certificatemanager’.
Successfully loaded plugin ‘search’.
Nov 02, 2018 7:08:13 AM com.sun.jersey.api.core.PackagesResourceConfig init
INFO: Scanning for root resource and provider classes in the packages:
org.jivesoftware.openfire.plugin
Nov 02, 2018 7:08:14 AM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version ‘Jersey: 1.19.4 05/24/2017 03:46 PM’
Successfully loaded plugin ‘monitoring’.
Finished processing all plugins.


#2

I had to remove http:// from the localhost and openfire links above as my account is new and it doesn’t like me posting links in my topics. I am using the full url.


#3

Something is awry because normally you’d expect to see the following in the output:

Admin console listening at http://<hostname>:9090

It may be that the admin console has been disabled - check what port is configured in conf/openfire.xml - the default is:

<jive>
    <adminConsole>
        <!-- Disable either port by setting the value to -1 -->
        <port>9090</port>
        <securePort>9091</securePort>
    </adminConsole>

Note that it can be disabled - that may have been what happened, deliberately or otherwise.


#4

Thanks for the info, right now the openfire.xml has this

<jive>
<adminConsole>
<!-- Disable either port by setting the value to -1 -->
<port>9090</port>
<securePort>9091</securePort>
</adminConsole>

Looks the same, anything else I should check?


#5

When you installed newest Openfire version, it has installed a service automatically and it is probably running. In that case running a launcher creates a conflict and you can’t access Admin Console (that’s why it doesn’t show the line about console being available). You shouldn’t use launcher anymore. Quit it, to be sure reboot the server, then just open a browser and go to Admin Console URL.


#6

First thing tomorrow before people get to the office I’ll try rebooting the server and viewing the web interface before opening the launcher. Thanks again for the helpful suggestions.