powered by Jive Software

Openfire still won't start - Could not create the Java virtual machine

I was a bit premature last night in thinking that my problem getting Openfire to start was solved.

/opt/openfire/logs/nhub.out shows:

Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.

/etc/sysconfig/openfire is as follows:

Set this to the path where openfire lives.

If this is not set the script will look for /usr/local/openfire, then

/opt/openfire.

#OPENFIRE_HOME=""

If there is a different user you would like to run openfire as,

change the following line.

#OPENFIRE_USER=“daemon”

If you wish to change the location of the openfire pid file,

change the following line.

#OPENFIRE_PIDFILE="/var/run/openfire.pid"

If you wish to explictly specific the location of the log directory,

you can set it here. Note that this applies to the logs generated outside

openfire itself. If you want to change the location of openfire’s own

logs, see the system property ‘log.directory’. If this is not set,

it will default to $OPENFIRE_HOME/logs.

#OPENFIRE_LOGDIR="/some/where/logs"

If you wish to set any specific options to pass to the JVM, you can

set them with the following variable.

#OPENFIRE_OPTS="-Xmx1024m"

OPENFIRE_OPTS=“Xmx256m”

If you wish to override the auto-detected JAVA_HOME variable, uncomment

and change the following line.

#JAVA_HOME=/usr/java/default

JAVA_HOME=/opt/openfire/jre

I’ve set the memory for Java to use 1024, 256, and left it uncommented too - same result.

I installed on a VPS running CentOs 5.3 w/384MB RAM burstable to 1024MBytes RAM from the RPM.

When I “/etc/rc.d/init.d/openfire start” I get the following:

Starting openfire:

and then the shell prompt again - no warnings or anything.

How can I troubleshoot this problem?

.

Okay I got the following now:

ps auxww |grep openfire

daemon 11308 3.6 0.1 678324 59864 ? Sl 07:09 0:02 /opt/openfire/jre/bin/java -server -Xms256m -Xmx512m -DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar

I read a post at: http://www.igniterealtime.org/community/message/194863#194863 which said to increase Java memory with the following flag: OPENFIRE_OPTS="-Xms256m -Xmx512m", so I changed /etc/sysconfig/openfire to reflect that.

Now I’m having problems reaching port 9090 on that server. I’ll check the docs to see about remote access/config, since everything I’ve read so far seems to be about accessing http://localhost:9090.

I’m going to leave this thread open for the time being , and will report back later. If anyone has any input pls feel free to comment

Kindest regards,

Bradley.

Okay I opened up a port and ran the setup just fine. I accepted the default name for the host that was pulled from the system info and used the internal database, and now I cannot login to the admin interface after completing the setup.

I’m going to close this thread as solved and open a fresh one up for the inability to login.