Openfire stops responding at least once per day

I’m running a very small Openfire server (5 users) on a Raspberry Pi. 1-3 times per day, the server disconnects all users and is inaccessible via the admin console. I can see that the process is still running, so it’s not crashing outright. Restarting the service brings it back to life.

Unfortunately, there’s nothing in the logs – timestamps don’t correspond to the times (or even days) when the server stops responding. It also doesn’t seem to be a memory issue, as I’ve been monitoring memory both in Linux in general and within the Openfire admin console (when it’s responding). I never see it get anywhere near maxed out.

If anyone has a suggestion, I’d appreciate it. I’m also wondering if there’s a way to log more information somehow, to try and narrow in on this. Without logs, I’m not sure how to go about debugging the problem. Thanks.

Openfire Version: 4.0.0 (and previously 3.10.3)

OS: Raspbian (Debian)

Bump. This is driving me crazy.

although not exactly the problem you’re having, you might give this a try

Possible workaround for users experiencing high cpu or memory under linux

We have a similar experience. From my gut feeling it became less stable since 3.10. We need to restart Openfire more regularly recently then before, (but not every day). At least it’s my impression.

Are you able to deploy an older version (3.9.3 preferably) to help narrow it down? (To see if it’s reproducible with 3.9.3)

Thank you for your help. This is not the solution for my problem, unfortunately – a few hours after setting the variable, I hit the same issue as before.

Thanks for your response. I wonder what the deal is. I downgraded to 3.9.3 and still had my same issue, unfortunately. If you see improvement on 3.9.3, this may just be a hardware issue on the Raspberry Pi (although I’m not seeing other issues on the machine).

1 Like

what value did you use on the variable? with a raspberry pi, I would prob use MALLOC_ARENA_MAX=1

Oh, that’s good to know. I did 4 as that link suggested, but I’ll switch to 1 and see if that works better. Thanks!

I feel like setting MALLOC_ARENA_MAX to 1 may have slowed it down, but I’ve still had my issue crop up a couple of times in the last two days.

For what it’s worth to others who may come across this thread from Google, I never found a solution. I switched to prosody (Prosody IM - Jabber/XMPP server ) which is a much lighter-weight implementation and was sufficient for my needs (and probably all one would ever need on a raspberry pi). That’s been running beautifully without any downtime for nearly two months now.