powered by Jive Software

Openfire system properties

Hello everyone, I am having some issues with the openfire system properties. I added xmpp.server.session.idleand put 1000 as value which means the user will b idle after 1 sec. This doesn;t seem to have any effect, I tried logging in using smack api and then leaving the user inactive for a long time but the user will still show as active on the admin console. Why is the system properties not working ? Am I missing something else? I also killed th openfire process and restarted it and this doesn’t seem to make any difference. I also entered the session timeout property as well and there is never a time out. I can log in then shut down my application and come back the next day and it will still show the users as active. I would appreciate some help here. thanks.

I also checked teh db and I can see that the properties are being correctly loaded. I tried setting 60000 ( 60sec) for timeout but this doesnt work.

±---------------------------------±------------------------------------------- ---------------------+
| name | propValue |
±---------------------------------±------------------------------------------- ---------------------+
| xmpp.server.session.timeout | 60000 |

Ok I found the answer to my own question…the thing i was looking for was xmpp.client.session

Question answered