powered by Jive Software

Openfire Upgrade Issues has started a chain reaction of issues

I upgraded to Openfire from 4.1.4 to 4.1.5. It seems to work fine for me however, now that employees are attempting to use it, spark (v 2.77) will not show any contacts. Just a blank space. You can add someone but that doesn’t show up either. My install will show users but it shows them as away even though I verified they are using their computer. So I attempted to downgrade back to 4.1.4 but it removed the openfire service. So how can I add the service feature on this version? I cannot find anything on the website.

Okay I figured out the service issue. However, I do still have concerns over why this happened. I’m not sure if it was a Spark issue not working with v4.1.5 or an Openfire issue. I attempted to install Spark v2.8.3 but when I do that, it cannot connect and will not let you log in. I am running Openfire on a Windows server 2008r2. DB is stored on a remote SQL server. Connected to active directory for logins.

I have just verified that 2.7.7 works with the latest Openfire version. I think that might be a bad update. If you had service running with Openfire 4.1.4, you had to stop it first as 4.1.5 can’t stop older service. If you have a backup, i would restore it and then do the update again, this time stopping the service first.