powered by Jive Software

Openfire using Active Directory and SQL but different Server Name

Hi,

I already have an Openfire setup that is bind with our Active Directory

so users have the same credentials what they use to login in Windows.

  1. Use MS SQL Server for conversation archive database while users still stick with their AD login credentials.

  2. In the Spark (Server textbox), they must use SparkServerName NOT the AD ServerName/ComputerName.

Is 1 and 2 possible to setup?

thanks in advance,

kikigak

Yes, this is how my environment is setup. Should just work out of the box.

Does it not work for you?

hi david,

yes, I’ve already implemented the Step 1 which I’m using:

  • Openfire 3.8.1

  • MS SQL Standard 2005 w/ SP4

  • MS Server 2008 R2 SP1

everythings fine but when I change config like these,

I added three (3) SRV in my DNS(which is Win2k8),

SRV 1:

service: _xmpp

protocol: _tcp

priority: 0

weigth: 100

port: 5269

hostname: jabber.example.local.

SRV 2:

service: _xmpp-server

protocol: _tcp

priority: 0

weigth: 100

port: 5269

hostname: jabber.example.local.

SRV 3:

service: _xmpp-client

protocol: _tcp

priority: 0

weigth: 100

port: 5222

hostname: jabber.example.local.

the FQDN of DNS Server is dc01.example.local and

I can ping jabber when I am logged in the Server dc01

but I cannot ping jabber or even jabber.example.local

on workstations even I manually added a HOST (A) as

jabber with same IP of dc01.

what did I miss something?

-kikigak

Either your DNS is wrong, or the IP you assigned to jabber.example.local is wrong. Hard to tell without knowing why ping doesn’t work - Was it unable to resolve the hostname, or unable to ping it? Can you ping the system by IP from other devices on the network?

Either way, you’ve got a network/AD issue, not an Openfire problem.

Hi David,

actually I can ping the jabber and jabber.example.local in other workstations

but it takes for about an hour to pass by. I mean when I restart the server,

I cannot ping it after it totally back on.

Is this really the nature when adding manually an SRV?

I have to wait for an hour to propagate the jabber/jabber.example.local?

if not then, how can I push/force the jabber SRV to update/propagate?

-kikigak

a SRV is no different to any other RR in DNS - I’m assuming your DNS server in your network config is actually your domain controller, and not some other system that might be caching it? jabber.example.local is supposed to be an A record, not SRV.

You might want to talk to whoever supports your network and see if they can help.

Hi David,

Perhaps I’ve set this up everything in fine but,

  1. Tester Login User is a not Domain Account so from there it takes some time to wait to ping jabber while Domain Users using their Workstation are normally fine after they logged in.

  2. Another point that I’ve seen is that this Tester Workstation has so many network connections like LAN, VM’s, WLAN and PPTP VPN. I disabled these except LAN then I can now ping jabber instantly after I logged in even using a not Domain User Account.

Workarounds,

  1. I move my LAN to the top/highest level in my Network Adapter Settings->Advance, still didn’t work after logged in.

  2. Disable WLAN Adapter, still didn’t work after logged in.

  3. Disable 2 VM Adaper (VMware Worskstation), and now I can ping jabber.

  4. Enable 2 VM Adaper (VMware Worskstation), and I can still ping jabber.

This VMware Adapter overides my DNS Resolution. I don’t know how to overcome with these 2 VM Adapters, it has Static IP assign by default from VMware that has different Network Address with our local network.

Post edit and add these,

In 2 VMware Adapters Properties under DNS tab, I uncheck “Append parent suffixes of the primary DNS suffix”, restart my Workstation and now I can ping jabber after I logged in.

Thank you David.

-kikigak

Message was edited by: kikigak

Hi,

Here I make a quick step procedure when I set this up.

I hope this could help someone.

-kikigak