powered by Jive Software

Openfire Web Administration Console - No Admins Set

Hi Guys,

I attempted to change the openfire administrator to include another user, but put the users in without a comma between them.

Now I cannot login to our web admin console and so cannot configure anything to do with Openfire.

We use the LDAP Active Directory integration and run the server on Windows Server 2003.

Could anybody advise how I can reset the administrator to how it was, or just how to change it outside of the admin console?

Any response is appreciated.

Thanks in advance,

Alex Grant.

you can do this 2 ways, both require editing the openfire.xml:

  1. Stop openfire server, edit the openfire.xml file to add:

adminuser

substitute real admin users in for adminuser, start openfire

  1. Stop openfire server, edit the openfire.xml file setup tag to read false, start openfire, go to the admin site and walk through the config again.

option 3rd way if using an external database: Find the table containg the admin users and fix the content.

Cheers Todd, I shall give this a go end of play today once everyone leaves.

Btw, Openfire was setup by the guys who rigged our network about a year ago and now I can’t get in contact with them - how would I find out if our Openfire uses an external database?

Thanks and Regards.

what version of openfire are you using? you can what type of db you are using by the db connection settings in the openfire.xml.

HI Todd,

Thanks for your help so far.

It is 3.6.3 and I’m not sure much else so here is my config.xml file…

9090 9091 en org.jivesoftware.database.EmbeddedConnectionProvider true true

you are using the embedded db which you can tell by this line: org.jivesoftware.database.EmbeddedConnectionProvider

Thanks Todd, I’m almost there!!

In terms of this embedded database, is this in java, or something openfire creates itself?

Also, is there a guide online that advises how to view this so that I can try to find the neccessary field and amend accordingly?

it is very difficult to edit the embedded db. it is a database engine but there are no decent tools for editing. You best bet is edit the openfire.xml file. You have the tag in your file. Just make it match what I posted earlier, substituting your AD usernames as needed.

Todd, that worked like a charm and all is now fixed.

Thanks a lot for all your help on this.

Cheers

You’re welcome.