powered by Jive Software

Openfire Websocket to WSS?

Hi again, and sorry for spam.

I’m working hard with openfire websocket plugin and its work fine.

I’m using SSL protocol in web, and I would like use wss instead of ws.

I guess I have to modify websocket server ( specifically websocket.jar ).

Some help? Is necessary modify websocket server? I’m triying change ws:// to wss:// manually, but i don’t get connection.

Thanks in advance

Use port 7443 instead of 7070 if you use wss:// instead of ws://

If I use ws and 7070 port, its work fine.

Hoewer, if I use wss protocol and 7443 port:

this.protocol=“wss:”;

  this._ws = new WebSocket(this.protocol + "//" + "server:7443" + "/ws/server?username=" + username + "&password=" + password + "&resource=" + resource, "xmpp"); 

I get :

doConnect- sparkweb.js:11420

Connection successfully established. sparkweb.js:11475

XMPP.WS - _onclose

seems that server refused connection

Edit:

https://server:7443/ is working fine

EDIT 2:

It’s working fine now.

My server url was invalid

How did you get it working? I am facing the same problem, this is my url “wss://localhost:7443/ws/”, and it doesn’t work.

Hello,

I am having issues making websocket work in Openfire 4.1.0 Alpha.

I checked the controlpanel

http://localhost:9090/plugin-admin.jsp

and Openfire WebSocket 1.1.3 is installed.

I tried both of these links

wss://localhost:7443/ws/

http://localhost:7443

and none of the link worked.

LOG

2016.11.03 10:23:35 uk.ltd.getahead.dwr.impl.ExecuteQuery - Exec[0]: downloader.installPlugin()

2016.11.03 10:23:43 org.jivesoftware.openfire.websocket.WebSocketPlugin - Initializing websocket plugin

2016.11.03 10:23:43 org.jivesoftware.openfire.container.PluginManager - Successfully loaded plugin ‘websocket’.

2016.11.03 10:23:43 org.jivesoftware.openfire.container.PluginMonitor - Finished processing all plugins.

I also tried

http://localhost:7070 and it works but the following is not working

wss://localhost:7070/ws

OR

ws://localhost:7070/ws

Please let me know what am I missing

1 Like

wss://…:7443/ws/ is not working for me !

Environment : localhost
Open-fire version : 4.3.2
How to make it working ?

do you have CA certificate or you have seld signed certificate try with some domain instead of localhost just to test