powered by Jive Software

Openfire will not startup under Mac OSX Mountain Lion?

Openfire was running great on Lion, but refuses to even start on Mountain Lion. Anyone get it running under Mountain Lion? I really don’t want to have to leave Openfire for a different solution for our company.

Thanks!

Not much help with the error message. Any idea where else to look? If I can’t resolve this by the end of the day I’ll have to push out another solution to our CS and Sale departments.

Thanks!

https://www.dropbox.com/s/nm22yx5hsqsebo0/Screen%20Shot%202012-07-25%20at%201.00 .26%20PM.png

Oh well, I guess the moral to the story is if you want to run Openfire do not upgrade to Mountain Lion and if you need to upgrade to Mountain Lion then look somewhere else for an in-house messaging solution.

Thanks Jive, I’ve enjoyed using your software while I could. Maybe once the issue is resolved with Mountain Lion and Openfire I might get a chance to come back. But as of right now we need something that works with Mountain Lion and don’t have time to wait for it to be fixed.

Thanks!

To those who have sent me messages…

  • openFire worked just fine under Lion until I upgraded to Mountain Lion this morning.
  • I am using the internal database.
  • Yes, I ried turning the firewall off.
  • Yes, I turned the new “Gatekeeper” option to allow any program to run and be installed.
  • Yes, I tried uninstalling and reinstalling openFire

None of the above has worked. It just looks like some work needs to be done by Jive before openFire will work with OSX Mountain Lion. Unfortunatly we don’t have time to wait as we depend on the daily inter-office communication that openFire provided us so we have to find another solution.

This is your warning, if you are running openFire on OSX do NOT upgrade to Mountain Lion or it will no longer startup.

Well that’s strange. When I came into my office this morning I was reserved to have to find a different solution. I gave openFire one last try and low and behold it started! I have not changed anything, no overnight reboot… nothing.

I’m not going to complain! Just happy to have it back!

Sounds like your installation just started magically working. I was not so lucky.

For whatever reason I think the mountain lion upgrade on my machine deleted the “openfire” userid on my machine. Given that the launchd script was failing to start for me.

I recreated the account and hacked on the launchd-wrapper script a tiny bit (removing the cat of the PID – which makes no sense to me).

Anyway, with those changes I’m up and running on ML now.

I don’t know if this is the issue you’re having, but i had a similar issue. The installation worked fine, but the service just would not start. The problem for me was as simple as Java was not installed, as Apple now don’t install it by default in ‘Mountain Lion’. To install it easily, just go to the /Applications/Utilities folder, click on ‘Java Preferences’. It will complain Java is not installed and would you like to download it, press yes. Problem solved.

Of course Apple are still on Java 6 and that is the last version they’re supporting. But i’m sticking with that for now as that is what works with Openfire so far.