Openfire with java1.4.2

How to … make run openfire service with lower version of java1.5

currently im using

Java™ 2 Runtime Environment, Standard Edition (build 1.4.2_04-b05)
Java HotSpot™ Client VM (build 1.4.2_04-b05, mixed mode)

openfire3_6_0 installed

if i run ./openfire then following error im getting…

No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.5.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
You can also try to delete the JVM cache file /root/.install4j

how to run openfire with upgrading java version.if anyone worked on this pls provide solution.

how to runopenfire without upgrading java version

Openfire uses Java 1.5 features in many places. This would probably require a lot of modifications. May be it does already use several 1.6 Features.

Why do you not want to upgrade to an newer Java? If you have some other old software which requires Java 1.4.2, this should be no problem. You can install multiple Java versions at the same time!

Thanks for response.

but without upgradation i require, some of present module may effect. some reasons are there, of course higher versions suuport lower also.

but without upgrading java, is there any other possible solution to run openfire please let me know.

i tried with uncommenting INSTALL4J_JAVA_HOME_OVERRIDE as current java version path

and modified ./openfire script providing $app_java_home … but … its nt running.


are you using Windows or Linux?


Linux 64 bit machine im using.



so you may want to read and use one non-privileged user like “jive” to install Java 1.6 and Openfire. As you never use root in this case (only to add the user) you can be sure that you do not break anything on the server and when you want to get rid of Openfire and only need to remove “/home/jive” - this will also remove Java 1.6.

With “chmod 700 /home/jive” (as root) you can make sure that only “jive” can access Java 1.6.