powered by Jive Software

Openfire with Jitsi self hosted server

Hello there!

So, I’ve been using Openfire for quite some time now, but just as a Intranet chat system, but now that a lotta people need to work from home, I’ve been getting requests to also provide video chat services.

I did install the meetings plugins and I’ve been using the PADA web client to connect and test video calls, but I need everything to be running on premises (we have a metropolitan network connected by fiber optics).

So, I’m reading the Jitsi docs to install a local server, but How would I make Openfire use my server instead of the jitsi official one?

And is there a Windows client (like spark) that I can use to make video calls ?

Just wanna say thanks in advance for any help/tips you guys can give me.

  • Bottom line, 100% self-hosted local setup with video calls and conferencing.
1 Like

Pàdé is basically Jitsi Meet incorporated into Openfire, so it should be everything you need. What exactly are you missing from Pàdé?

Well the problem for me is that PADE still uses jitsi servers (from what I can tell since the share link on a video uses jitsi, and I need it to be working locally so even if our wan links fail we still can video conference.

I found a couple good tutorials on how to install jitsi (hopefully it will work), I just have to figure out now how to make PADE use a local jitsi server instead of the one it currently uses.

Hm, I thought pàdé would use the local server only. @Dele_Olajide can you clarify?

1 Like

Just to make the issue a bit more clear, heres a screenshot (I didnt have the time to net analyze the generated traffic , but I will run an isolated server soon as I can to see what’s being used exactly when it comes to external assets.

2020-04-01 15_19_50-Pade - Unified Communications at Work _ rdc-u2bm93fhq

In pade for work, I think changed in the settings>meetings>general settings…look for base url and add your url for your hosted jitsi

1 Like

Well, I think we are on the right path here, I did change the general settings “base url” to see if ti would do something and I used https://SERVER-IP-HERE:7443/ofmeet/ (I Just lost the vm I was working on jitsi, so I gonna have to start from scratch)

The links are changed to the local server ones.

Now I’m new to the whole PADE thing, so from what I understand, Openfire, plus all the plugins

2020-04-01 18_21_09-Openfire Admin Console_ Plugins

Still gonna need a jitsi local server to bridge the video calls and so on.

I’m gonna search the docs to try understand how the whole thing is connecting, but If someone could just shed a let on this whole thing.

Thanks for the quick replies guys! I’ve been using Openfire since 2012, so I just would love to get PADE working like I need to.

1 Like

I recomend the the ofmeet plugins customized for pade. They have latest jitsi code and a few more features than the official ofmeet plugin. You can find them here

You need both offocus and ofmeet unlike the official ofmeet plugin which has combined them.

Running jitsi meet on a coporate network behind a firewall and possibly a NAT can be tricky. Things to watch out for are:

  1. you need to add /etc/hosts entries on your server to map your domain name and server name to 127.0.0.1
  2. you need to configure the nextwork section of ofmeet in openfire admin web console and provide the public and private IP addresses of your openfire server.

You can check that the server will work by confirming the focus bot user has logged in ok like this
image

If that is the case, then open two browser tabs and go to a test conference like this https://your-server:7443/ofmeet/testconf and confirm that it is showing in the conference summary like this

image

This confirms focus bot user is working, to confirm your videobridge is working, run the test again with 3 users.

1 Like

Hello There! Thanks again Dele, I did download from github and now everything works like a charm.

Great job you guys are doing with openfire and it’s plugins, can’t thank you enough for your efforts.

Ahh, and thank for the tips, since I have an active directory providing domain services on the internal network and dns it seens to have worked quite fine.

I’m also running a public test server and things are looking quite good, it’s the solution I needed (especially now that Zoom is so full of bugs and security problems)

1 Like