Openfire with MS-SQL as Database - I Beg for Helped

Hello people… i just want information on how database works using ms-sql as backend of openfire database. its been 30 days since my last installation of openfire and got 300+ users on it. my problem is when i saw my server drive C space i got a low disk space prompt when i saw it (See Attached file). 13gig.+ i have a daily backup settings on my sql 2000. and i enabled archive loging of messages full.

Any of you got an advised on how to limit the .LDF extension of the database? i hope you can help me here…

Thank you so much People…

Use this script to shrink your log files.

Sometimes you have to run in twice to reduce the log size.

Thanks for the script … i review the script and i think its helpfull. but i have a another way around in MS-SQL server 2000 theres a shrink features there but im not using it i manage to adjust the option to disabled grow file something like that and delete the database and restore the backup i still got the 13gig log but it didnt grow anymore… i dont know… what happen…

I have a 43GB log file on my system. I’m currently running the script in question. I hope it works. It seems pretty strange that such a simple application would suck up so many resources.

My big question is would it be advantageous to limit the log file once it’s shrunk or will that cause problems?

This script didn’t work for me. At least it didn’t think there was anything to do:

Original Size of openfire LOG is 5411408 8K pages or 42276MB

Final Size of openfire LOG is 5411408 8K pages or 42276MB

I really would like to get this thing reduced!! Anyone out there can help?

I spoke too soon!

I changed the recovery mode from “Full” To “Simple” on the options tab of the database. The log file immediately went to 1MB. I can’t imagine there is anything in the database that is so important I can’t simply use a normal backup to restore from the last night’s backup.

Changing the model from Full to simple did not shrink the transaction log for me. It looks like it is still growing.


  1. First we need to change Recovery model to “Simple” from “Full”

  2. Shrink database.