powered by Jive Software

Openfire wont start after install

Hey All,

I just downloaded the software and installed it however cant seem to get the service to start. I’ve been digging around google for some time but it appears my google fu is weak. Any have any idea why the service just wont start or how I should diagnose this?.

I’m running Fedora 14 x64 fully updated, Disabled firewall and SELinux

[owner@deathstar ~]$ uname -a
Linux deathstar 2.6.35.10-74.fc14.x86_64 #1 SMP Thu Dec 23 16:04:50 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
[owner@deathstar ~]$ sudo /etc/init.d/openfire status
openfire is not running
[owner@deathstar ~]$ sudo /etc/init.d/openfire start
Starting openfire:
[owner@deathstar ~]$ sudo /etc/init.d/openfire status
openfire is not running
[owner@deathstar Downloads]$ ls
openfire-3.6.4-1.i386.rpm

1 Like

Not 100% sure how this goes on Fedora, but below what I have to do to get any daemon (well most) running on FreeBSD

Add the following lines to /etc/rc.conf.local or /etc/rc.conf

to enable this service:

openfire_enable (bool): Set to NO by default.

Set it to YES to enable openfire.

other options:

openfire_user (username): Set to openfire by default.

Set it to required username.

openfire_group (group): Set to openfire by default.

Set it to required group.

openfire_libdir (path): Set to /usr/local/share/java/classes by default.

Set it to java classes directory.

openfire_home (path): Set to /usr/local/share/java/openfire by default.

Set it to java home directory.

openfire_javargs (args): Set to -Xmx256M by default.

See java -h for available arguments.

Just Googled for you:

http://www.thelinuxblog.com/adding-a-service-on-fedora/

Thanks for the reply, Those files don’t exist in my OS :-/
As far as I can see everyone just installs and then kick off the service and it works. I tried 2 installs on this OS and it just wont start.

Some more logs, The messages in /var/log show nothing useful.

[root@deathstar log]# cd /opt/openfire/logs/
[root@deathstar logs]# ls
nohup.out
[root@deathstar logs]# cat nohup.out
nohup: failed to run command `/opt/openfire/jre/bin/java’: No such file or directory
[root@deathstar logs]# /opt/openfire/jre/bin/java
bash: /opt/openfire/jre/bin/java: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
[root@deathstar logs]# cd …/jre/bin/
[root@deathstar bin]# ls
ControlPanel java java_vm jcontrol keytool orbd pack200 policytool rmid rmiregistry servertool tnameserv unpack200

I installed 32x Fedora and its working. My only guess is that i would need to compile for 64x. Anyways. Just wanted to throw a heads up and let you guys know that the problem is solved.

I got it to start on RHEL 6 64 bit by installing the 32 bit library

yum install libldb.i686

1 Like

It’s actually just zlib.i686 it needs. Installing libldb isn’t necessary, but it installs zlib as a dependency.

1 Like

I just jumped through all the hoops necessary to register for this forum in able to compliment Gary for this solution. It worked for me running Fedora 2.6.35.6-45.fc14.x86_64 #1 SMP.

Can the RPM be re-bundled to require the libldb.i686? This is a rather non-intuitive issue to troubleshoot.

Thanks, Gary.

mtf

OF-489

I just installed CentOS 6 and am trying to transfer my openfire install fromcentos 5.6 to centos 6.

I installed it and did not get any warnings about files not being found butit will not start.

I tried to start it manually with the openfire.sh and received the following


[root@***** bin]# sh openfire.sh

ls: cannot access /usr/java/j*: No such file or directory

openfire.sh: /opt/openfire/jre/bin/java: /lib/ld-linux.so.2: bad ELFinterpreter: No such file or directory

openfire.sh: line 162: /opt/openfire/jre/bin/java: Success

[root@*****bin]#

this is centos 6 32-bit.

[root@***** bin]# cat /etc/redhat-release

CentOS Linux release 6.0 (Final)

I am new to the forums so please help me if i placed this in the wrong spot


I would just like to give Kudos to Gary. The installation process warns that it is not supported on 64bit and they weren’t kidding. However, the log file could have been a little more clear about the issue. After following his suggestion it worked like a charm. +1 to you sir.

I just installed Sun/Oracle 64bit JRE and use that instead of the one which ships with Openfire - Works fine on my 64bit systems.

This is how you solve it. I run it under CentOS 6.2 64 bit.

http://www.webhostingskills.com/articles/solving_the_problem_installing_openfire _on_centos_64_bit

i have the same issue on my server centos 6.2 64 bit install on a 64 bit hp server i get the following message pls pls help me get this working ;(

root@oilzone1 [~]# rpm -ivh openfire-3.7.1-1.i386.rpm
Preparing… ########################################### [100%]
1:openfire ########################################### [100%]
Error: JAVA_HOME is not defined correctly.
Can not sure execute /usr/local/jdk/bin/java.
root@oilzone1 [~]# java -version
java version “1.6.0_22”
OpenJDK Runtime Environment (IcedTea6 1.10.6) (rhel-1.43.1.10.6.el6_2-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

thanks for the help

AND YES i did try installing that libldb.i686 but it didnt seem to make a difference… same error …what do i need to change something

Is your JDK installed under /usr/local/jdk/bin? Probably not. You’ll need to change the JAVA_HOME to reflect the real install location of your JRE/JDK.

I’ve never tried to run Openfire under the OpenJDK which ships with RedHat, but I’m running Openfire on RHEL6.2 using Oracle JRE 1.6u31 without any problems.

I don’t even have java installed and openfire is working just fine.

Last login: Sat Apr 21 19:40:59 2012 from 172-16-4-195

[poijn@den ~]$ su -

Password:

[root@den ~]# rpm -qa | grep java

[root@den ~]# yum list java

Loaded plugins: fastestmirror, security

Loading mirror speeds from cached hostfile

Error: No matching Packages to list

[root@den ~]# java-version

-bash: java-version: command not found

[root@den ~]# uname -a

Linux den.alliant.edu 2.6.32-220.el6.x86_64 #1 SMP Tue Dec 6 19:48:22 GMT 2011 x86_64 x86_64 x86_64 GNU/Linux

[root@den ~]#

Openfire ships with a JRE - Usually it is under /opt/openfire/jre/

/opt/openfire/jre/bin/java -version

java version “1.6.0_21”

Java™ SE Runtime Environment (build 1.6.0_21-b06)

Java HotSpot™ Server VM (build 17.0-b16, mixed mode)

You need to run ‘java -version’, or do a rpm search for ‘jdk’ or ‘jre’. Surprised your search did not find openjdk which ships with RHEL.

[root@rhesproddns01 dump]# rpm -qa | grep -i jdk

java-1.6.0-openjdk-1.6.0.0-1.42.1.10.4.el6_2.x86_64

I sloved by:

cd /opt/openfire/jre/bin

cp java java.bak

rm java

ln -s /usr/bin/java java

service openfire start

OK.

CentOS6 64bit

1 Like

I also went through the trouble of registering to thank everyone for their help! Someone linked a URL that really helped, but that website was down. Thankfully Google had text cached the page. Here it is:

Solving the problem installing Openfire on CentOS 64-bit

There is a slight problem with installing Openfire on the latest CentOS 6 64-bit. The server is placed perfectly, runs. Check the status of the server after installation: /etc/init.d/openfire status and see openfire is not running.

Go to the folder with log: /opt/openfire/logs/nohup.out and watch the result of start-up and no error java in the folder /opt/openfire/jre/bin. The file is there, but the problem is that required for Openfire version of the library for 32-bit.

The following problem is solved, set the desired library libldb.i686 type command:

> yum install libldb.i686 zlib.i686

Next restart Openfire:

> service openfire restart

and check the status of:

> /etc/init.d/openfire status

and see that everything is in order now and we have changed the status to running.

These are the notes I took using the minimal ISO for CentOS 6.4 64-bit. Hope they help someone else!

Fresh Install of CentOS v6.4 x64 on 8/28/2013. Used ISO called “CentOS-6.4-x86_64-minimal.iso”.

Commands Ran:

“yum groupinstall base” - Installs basic packages we need like Perl, wget, etc…

“service iptables save”

“service iptables stop”

“chkconfig iptables off”

“yum install zlib.i686”

“yum -y update” to update operating system

“cd /tmp”

“wget http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire-3.8.2-1 .i386.rpm

“rpm -ivh openfire-3.8.2-1.i386.rpm” to install

1 Like

As mentioned previously, libldb.i686 is not required, so you need only do:

yum install zlib.i686

I have the same issue

*[root@spark logs]# cat nohup.out *

nohup: failed to run command `/opt/openfire/jre/bin/java’: No such file or directory

Except I have zlib install

*[root@spark bin]# yum install zlib.x86_64 *

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

_ * base: centos-distro.cavecreek.net_

_ * extras: centos.mbni.med.umich.edu_

_ * updates: centos.mirror.ndchost.com_

Setting up Install Process

Package zlib-1.2.3-29.el6.x86_64 already installed and latest version

Nothing to do

and java

[root@spark bin]# pwd

/opt/openfire/jre/bin

[root@spark bin]# ls -l

lrwxrwxrwx. 1 daemon daemon 10 Sep 13 08:10 ControlPanel -> ./jcontrol

-rwxr-xr-x. 1 daemon daemon 47308 Feb 8 2013 java

-rwxr-xr-x. 1 daemon daemon 25634 Feb 8 2013 java_vm

-rwxr-xr-x. 1 daemon daemon 89387 Feb 8 2013 javaws

-rwxr-xr-x. 1 daemon daemon 6407 Feb 8 2013 jcontrol

-rwxr-xr-x. 1 daemon daemon 47447 Feb 8 2013 keytool

-rwxr-xr-x. 1 daemon daemon 47679 Feb 8 2013 orbd

-rwxr-xr-x. 1 daemon daemon 47515 Feb 8 2013 pack200

-rwxr-xr-x. 1 daemon daemon 47807 Feb 8 2013 policytool

-rwxr-xr-x. 1 daemon daemon 47447 Feb 8 2013 rmid

-rwxr-xr-x. 1 daemon daemon 47447 Feb 8 2013 rmiregistry

-rwxr-xr-x. 1 daemon daemon 47475 Feb 8 2013 servertool

-rwxr-xr-x. 1 daemon daemon 47679 Feb 8 2013 tnameserv

-rwxr-xr-x. 1 daemon daemon 190106 Feb 8 2013 unpack200

Previously Openfire 3.7.1-1 installed without issue on CentOS6.4 64-bit.