powered by Jive Software

Openfire XMPP Server cannot be installed on the disk. A Newer version of this software already exists on this disk

Hi Team,

First I have installed Openfire 3.10.x on my MAC. But as per my application requirement i need it 3.8.1. So i thought of downgrade to 3.8.1.

After uninstalling 3.10.x, based on this post(How to UNinstall OpenFire for Mac? ) tried to install 3.8.1. i am getting below message on 2nd step.

“Openfire XMPP Server cannot be installed on the disk. A Newer version of this software already exists on this disk”

Also manually deleted all openfire related file. still getting same message.

Any Idea? How to resolve this?

1 Like

Hi there, I know this is an old post, but I was having this same issue and solved it. In my case it was a mac on ‘Snow Leopard 10.6.8’ which needed ‘Openfire’ to be downgraded from 4.1 to 3.6; so I tried modifying the file ‘Info.plist’ located inside the Openfire.pkg of the version that needs to be installed:

  1. Copy ‘Openfire.pkg’ file from the mounted disk image to a folder you can modify (I simply copied it to my desktop).
  2. Secondary click the ‘Openfire.pkg’ you just copied and select ‘Show Package Contents’.
  3. Navigate to ‘Openfire.pkg/Contents/’ and edit Info.plist using your favorite editor (I just used TextEdit).
  4. Go to line 11 (right below CFBundleShortVersionString) and change <string>3.8.1</string> into <string>3.10.6</string>
  5. Go to line 15 and change <integer>8</integer> into <integer>10</integer>
  6. Save the changes (in my case TextEdit showed a dialog confirming to overwrite even though the file is locked, I pressed ‘Yes’).
  7. Double click your modified ‘Openfire.pkg’ to run the installation normally.

You can also try downloading Openfire 4.1.6 (latest version right now) install this version, then use the installer I modified so you can try to ‘force install’ version 3.6.4; after that you can install the version you need which is newer.
Openfire 3.6.4 FORCED INSTALLER
Openfire 3.8.1

1 Like