powered by Jive Software

openfireHome - Home not found

I know that there is a bunch of stuff here on the forums about this, however there is really no true blue 100% solution for it. Is there something out there that someone can help me with in regards to this. I have made sure 5 different times now that everything is installed correctly and in “working” order. However when I go to the admin console to go through the remailing setup I always get this.

“Openfire Classes Home not found. Define system property “openfireHome” or create and add the openfire_init.xml file to the classpath”

The only thing I have not tried is downloading the RPM version which is something I can’t figure out how to do at this current point in time (If it’s even still available). I will be using this for an inner-company IM system so to speak and would like as much assistance with this as possible.

I have setup openfire in the past without any issues. Could it be perhaps that I am using Ubuntu 10.04 LTS Server? Is there something new in this verison of the server OS that is causing a problem? If this is the case then I guess I need to find 9.04 and downgrade. Any help would be useful and most appreciated.

Kindest Regards,

  • ITG Systems Admin

I can’t speak for linux, but have you tried installing on a windows server? I’ve deployed many on windows without any issues.

I could install a windows server yes…however I don’t have a windows install that I could put on such an old machine. I don’t think it could even run XP with how old and how low the system specs are. That is the reason why I have a server based linux install. I guess if it comes down to it I could try installing XP on the machine and see if it will work.

-ITG Systems Admin

you could use an existing server. Openfire doesn’t require alot of resources. It doesn’t need a designated box.

Its the only server I have right now…so an existing server it is. I just need to figure out what is causing that error…any thoughts?

Hi,

I wonder whether you start script fails to change the directory after the su switch. Anyhow you could try to edit the script which launches Openfire and add to the java call “-DopenfireHome=/pathto/openfire”.

LG

So would that be put in there with or without the quotes? Here is the

funny thing that I have found. It does the same exact thing even in

Ubuntu Server 9.10 … the only way I can get it to run officially in

9.10 is by running it as root “sudo”. Is there something I did wrong

that I can’t run it as a normal user?

Hi,

I did post some start scripts in the documents section of this forum. My rc scripts does basically su - $USER -c "/home/$USER/bin/openfired ${OPTION}"´ and I use a customized openfired script which starts Openfire withcd ${HOME}/bin && nohup ${JVM} ${JAVA_OPTS} -jar …/lib/startup.jar >…/logs/STDOUT.log 2>…/logs/STDERR.log &´

If you did start it as root one time you may need to check the file permissions / owner inside the openfire directory and make sure that $USER has access to all files.

LG

Hello,

I had that error , What I found my onwer / group was not correct.

For Fedora 12 needed to be

drwxr-xr-x 15 daemon daemon 4096 2010-08-30 07:53 openfire

to change

chmod -R daemon:daemon openfire

my openfire is under /opt

1 Like

Cheers Scott.

I had the same prob and based on your post I changed group permissions on the home dir…success!!!

ps axw | grep openfire

/usr/local/openjdk6/bin/java -server -jar -Xmx256M -Dopenfire.lib.dir=/usr/local/share/java/openfire/lib -DopenfireHome=/usr/local/share/java/openfire

chown openfire:openfire /usr/local/share/java/openfire