OpenLDAP and PosixGroup


I have problem with posixGroup. In OpenLDAP exists group Test and is defined 6 memberuid. This group i filtred with






In OpenFire Admin i see this group Test but have 0 member.

When i run ldapsearch from jabber server i see groop correctly.


root@jabber:~# ldapsearch -x -b ‘dc=domain,dc=cz’ ‘(objectClass=PosixGroup)’

extended LDIF


base <dc=domain,dc=cz> with scope subtree

filter: (objectClass=PosixGroup)

requesting: ALL


dn: cn=test,dc=domain,dc=cz

cn: Test

gidNumber: 500

memberUid: jan.novak

memberUid: karel.macha

memberUid: jan.neruda

memberUid: ivan.olbracht

memberUid: karel.capek

description: Test

objectClass: posixGroup

objectClass: top

search result

search: 2

result: 0 Success

numResponses: 2

numEntries: 1


Thanks with help. Where is problem ?

Try tu use this entry:


This filter i also used, but same efect. Group Test have 0 member.

Have you tried to clean group cache on OpenFire?

What I have is

Group Field: cn

Member Field: memberUid

Description Field: description

Posix Mode: Yes

Group Filter: (&(objectClass=posixGroup))

I have wrong

Member Field: member

your setings is Good

Member Field: memberUid

Thanks you very much

Please check as answered.