powered by Jive Software

Openldap crypt auth

by default user passwords are stored with in OpenLDAP. I can’t log onto admin panel (same as any client in ldap directory cant log to IM). OpenLDAP is compiled wiht crypt support. Any suggestions?

Besides enabling crypt (./configure --enable-crypt), we had to also set the default password-hash to crypt.

Now when we move our NIS data to LDAP, all password authentications will be assumed to be crypt. This works with openfire 3.3.3

slapd.conf:

  1. For NIS Compatibility

password-hash

password-crypt-salt-format “$1$%.8s”