powered by Jive Software

Opnefire Plug-in Meetings


#1

Hi all,

I installed the plug-in of meetings, and when trying to perform a simple test, I get these errors in console:

[modules/UI/videolayout/LargeVideoManager.js] <>: hover in %s 4d8ziqiw
[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: non-anonymous rooms not supported
at ChatRoom.js:365
at s.Handler.handler (strophe.js:3384)
at s.Handler.run (strophe.js:2556)
at strophe.js:3822
at Object.forEachChild (strophe.js:1522)
at s.Connection._dataRecv (strophe.js:3810)
at e.Websocket._onMessage (strophe.js:6323)
[modules/xmpp/ChatRoom.js] <>: non-anonymous rooms not supported
[modules/UI/videolayout/LargeVideoManager.js] <>: hover in %s 4d8ziqiw

Any ideas?

Thanks in advance!


#2

Did you create the MUC room?


#3

Hi Dele_Olajide, thank’s for you reply.

I’ve a rare situation:

If I don’t create the room before, (y put the name on the form that appears wen I enter on https://server.name:7443/ofmeet/), the app shows the message of “non-anonymous rooms not supported”, but everithing works right, (we can see the image of the remote camera).

But, I create before in OpenFire Admin Console the room, and I put the room name on the form that appears wen I enter on https://server.name:7443/ofmeet, the app don’t show any error of “non-anonymous rooms not supported”, but I can’t see the image of the remote camera.

Please can you help me? Do you have any reason for this rare situation?

Thanks in advance!


#4

Take a hard good look at the room features and config data of both situations and compare. In the first case, Jitsi is creating a temp room while in the second case, you are creating the room with the default openfire room creation template. Try and match Jitsi when you create the room.


#5

Thank’s for your reply Dale! Now, It looks more beautifull, but now have a really extrange situation…

If 2 users enter on a room, everyting work right, but wen one third user is added, the video stop in all users… wen the third user leve the room, users 1 and 2, show another time video correctly.

Do you have ani idea about wats can be happend?


#6

This is usually the case when there is no media (audio/video) flowing between JitsiVideobridge and each peer over UDP port 10000 (unless you changed it in admin web page). With 2 people, media flows P2P with no server involvement to keep bandwidth costs down.

Is openfire behind a firewall or NAT?


#7

Also watch out for this gotcha with openfire 4.2.3

Stream management should be switched off otherwise, the focus user will disconnect randomly


#8

Hi! Thanks one more time for your answer Dele.

I put te properties stream.management.active = false and stream.management.requestFrequency = 0, but it don’t solve anything that i see.

This is the rest of the properties of jitsi.videobrigde.media that I have:

As aditional information I must explain that it’s a server on Microsoft Azure. Maybe this is relebant information for you. And that is the configuration of the rules in the virtual server:

I’m very losed for this situation… because I try to deploy on clean server in Azure only with Jitsi Server, and all work’s right… but in my Openfire server whit ofmeet plug in I can not do that it works fine.

Maybe this helps you: In the second server that i explain that only has Jitsi Server, I must put these two entries on the sip-communicator.properties file:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=x.x.x.x
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=y.y.y.y

Because if I don’t put them, it dosn’t works fine, and the situation was the same that I’ve in my Openfire server whit ofmeet plug in.

Really I hope that information was valuous for you help.

Regards
Daniel


#9

Hi Dele,

After my today answer, I continue trying, and I see that If I open all incoming ports, all works fine! Please can you have a look at my last answer, and say to me what port I forget to open?

Thanks one more time!


#10

Finally I found the solution.

I close all ports, and only open these ones:

The problem was the next entries was not configurable with user interface of Openfire meeting plug in, but wen I look the code of the plug in in GitHub, I see them!

After generate these two properties, all works fine!

imagen

Maybe be a good point that user interface of the Openfire meeting plug, allow these params was editable.

Regards


#11

You can edit both values


#12

Hi Dele!

I try this few days ago, but these options generate diferent parameters:

The yelow params are generated by the user interface that you say. And the last ones are that I say.

imagen

Regards


#13

Thanks for pointing it out. I think Guus refactored the code and removed the old org.jitsi.videobridge versions of localAddress and public Address params. I will raise an issue on this. Thank you for your patience and determination to get to the bottom of this :slight_smile:


#14