Outgoing route.all-resources

Hello.

I enabled route.all-resources and its working fine for incoming messages. I need to enable it also for outgoing messages.

resource1@domain Sends message to resource2@domain.
Message successfully delivered to resource2@domain/1 AND resource2@domain/2

The problem is when resource2@domain/1 sends a message resource2@domain/2 is never notified about new message.

Is there any built-in feature to achieve this?

Openfire supports XEP-0280: Message Carbons, which keeps all IM clients for a user engaged in a conversation. Outbound messages are carbon-copied to all interested resources.

This feature is enabled in Openfire by default. If a client wants to use the Carbons protocol, it needs to enable it by sending an IQ stanza containing a child element <enable/> qualified by the namespace “urn:xmpp:carbons:2” as shown in the following example:

Client enables Carbons:

<iq xmlns='jabber:client' 
  from='romeo@montague.example/garden' 
  id='enable1' 
  type='set'> 
  <enable xmlns='urn:xmpp:carbons:2'/> 
</iq>

You can verify availability of the Message Carbons protocol in the Openfire Admin Console under Sessions => Client Sessions => Sessions Details:

Carbons enabled

Would this work for you?

3 Likes

Im not sure im needing help